aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-03-27 19:38:05 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-03-27 19:38:05 +0000
commit61ee283899fb0a5df92787302e80f84b4d4aa755 (patch)
tree3f7a213cedd5344978b9bb9423729fe0dc8d2237 /target/linux/ar71xx/image
parent1094dc19962dae9c5181ebbbc2922688cb843e67 (diff)
downloadupstream-61ee283899fb0a5df92787302e80f84b4d4aa755.tar.gz
upstream-61ee283899fb0a5df92787302e80f84b4d4aa755.tar.bz2
upstream-61ee283899fb0a5df92787302e80f84b4d4aa755.zip
ar71xx: remove the built-in MTD map of the PB92 board
Pass the mtd_layout via the kernel command line instead SVN-Revision: 31111
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index d6fc008954..2203bec2e5 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -679,8 +679,9 @@ define Image/Build/Profile/PB44
endef
pb92_cmdline=board=PB92 console=ttyS0,115200
+pb92_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,2752k(rootfs),896k(kernel),64k(nvram),64k(art)ro,3648k@0x50000(firmware)
define Image/Build/Profile/PB92
- $(call Image/Build/Template/$(fs_64k)/$(1),AthLzma,pb92,$(pb92_cmdline),,917504,2818048,KRuImage)
+ $(call Image/Build/Template/$(fs_64k)/$(1),AthLzma,pb92,$(pb92_cmdline),$(pb92_mtdlayout),917504,2818048,KRuImage)
endef
wp543_cmdline=console=ttyS0,115200