aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-03-27 19:38:04 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-03-27 19:38:04 +0000
commit1094dc19962dae9c5181ebbbc2922688cb843e67 (patch)
tree365f3da4783bb16a9f5b66c4895f2136e19a941c /target/linux/ar71xx/image
parent24554ef187a883dd2ab0404a594fb4e731e288d9 (diff)
downloadupstream-1094dc19962dae9c5181ebbbc2922688cb843e67.tar.gz
upstream-1094dc19962dae9c5181ebbbc2922688cb843e67.tar.bz2
upstream-1094dc19962dae9c5181ebbbc2922688cb843e67.zip
ar71xx: remove the built-in MTD map of the Zcomax devices
Pass the mtd_layout via the kernel command line instead. SVN-Revision: 31110
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index cfffb89619..d6fc008954 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -995,12 +995,13 @@ define Image/Build/Profile/WZRHPG450H
$(call Image/Build/Template/$(fs_64k)/$(1),WZRHPG30XNH,wzr-hp-g450h,$(wzrhpg450h_cmdline),WZR-HP-AG450H)
endef
-zcn1523h28_cmdline=board=ZCN-1523H-2 console=ttyS0,115200
+zcn1523h_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,6208k(rootfs),1472k(kernel),64k(configure)ro,64k(mfg)ro,64k(art)ro,7680k@0x50000(firmware)
+zcn1523h28_cmdline=board=ZCN-1523H-2 console=ttyS0,115200 $(zcn1523h_mtdlayout)
define Image/Build/Profile/ZCN1523H28
$(call Image/Build/Template/$(fs_64k)/$(1),Zcomax,zcn-1523h-2-8,$(zcn1523h28_cmdline))
endef
-zcn1523h516_cmdline=board=ZCN-1523H-5 console=ttyS0,115200
+zcn1523h516_cmdline=board=ZCN-1523H-5 console=ttyS0,115200 $(zcn1523h_mtdlayout)
define Image/Build/Profile/ZCN1523H516
$(call Image/Build/Template/$(fs_64k)/$(1),Zcomax,zcn-1523h-5-16,$(zcn1523h516_cmdline))
endef