aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/files
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2018-02-16 20:30:38 +0100
committerPiotr Dymacz <pepe2k@gmail.com>2018-02-22 18:53:22 +0100
commitd6f187f9389d67c2e9c8bf253c6566388a0522d3 (patch)
tree616b180892466e2ea145b80496d205b4ef6b1d0e /target/linux/ar71xx/files
parentf4871333227afd6ff77bbea6e408404d24c484c7 (diff)
downloadupstream-d6f187f9389d67c2e9c8bf253c6566388a0522d3.tar.gz
upstream-d6f187f9389d67c2e9c8bf253c6566388a0522d3.tar.bz2
upstream-d6f187f9389d67c2e9c8bf253c6566388a0522d3.zip
ar71xx: add support for YunCore T830
YunCore T830 is a simple N300 router with 5-port FE switch, detachable antennas and USB 2.0 port. Specification: - 650/597/216 MHz (CPU/DDR/AHB) - 128 MB of RAM (DDR2) - 16 MB of FLASH (SPI NOR) - 5x 10/100 Mbps Ethernet - 2T2R 2.4 GHz (QCA9531), with ext. PA (SKY65174-21) and LNA - two external, detachable antennas (RP-SMA) - 1x USB 2.0 - 8x LED (7 driven by GPIO) - 1x button (reset) - DC jack for main power input (12 V) - UART and JTAG headers on PCB Flash instruction: 1. First, gain root access to the device, following below steps: - Login into web gui (default password/IP: admin/192.168.188.253). - Go to "Advanced" -> "Management" -> "System" and download backup of configuration (bakfile.bin). - Open the file as tar.gz archive, edit/update "shadow" file and change hash of root password to something known. - Repack the archive, rename it back to "bakfile.bin" and use to restore configuration of the device. - After that, device will reboot and can be accessed over SSH. 2. Then, install OpenWrt: - Login over SSH and issue command: fw_setenv bootcmd "bootm 0x9f050000 || bootm 0x9fe80000" - Upload "sysupgrade" image and install it (only if previous command succeeded) with command: "sysupgrade -n -F openwrt-...". Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/files')
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt10
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-t830.c127
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h1
4 files changed, 139 insertions, 0 deletions
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index da3cf63cef..7c0494bcc8 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -1129,6 +1129,16 @@ config ATH79_MACH_SMART_300
select ATH79_DEV_M25P80
select ATH79_DEV_WMAC
+config ATH79_MACH_T830
+ bool "YunCore T830 support"
+ select SOC_QCA953X
+ select ARH79_DEV_ETH
+ select ARH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+
config ATH79_MACH_TELLSTICK_ZNET_LITE
bool "TellStick ZNet Lite"
select SOC_AR933X
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index cea297af87..181e23a37a 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -190,6 +190,7 @@ obj-$(CONFIG_ATH79_MACH_SC450) += mach-sc450.o
obj-$(CONFIG_ATH79_MACH_SMART_300) += mach-smart-300.o
obj-$(CONFIG_ATH79_MACH_SOM9331) += mach-som9331.o
obj-$(CONFIG_ATH79_MACH_SR3200) += mach-sr3200.o
+obj-$(CONFIG_ATH79_MACH_T830) += mach-t830.o
obj-$(CONFIG_ATH79_MACH_TELLSTICK_ZNET_LITE) += mach-tellstick-znet-lite.o
obj-$(CONFIG_ATH79_MACH_TEW_632BRP) += mach-tew-632brp.o
obj-$(CONFIG_ATH79_MACH_TEW_673GRU) += mach-tew-673gru.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-t830.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-t830.c
new file mode 100644
index 0000000000..ffdb2ca533
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-t830.c
@@ -0,0 +1,127 @@
+/*
+ * YunCore T830 board support
+ *
+ * Copyright (C) 2018 Piotr Dymacz <pepe2k@gmail.com>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define T830_GPIO_LED_LAN1 16
+#define T830_GPIO_LED_LAN2 15
+#define T830_GPIO_LED_LAN3 14
+#define T830_GPIO_LED_LAN4 11
+#define T830_GPIO_LED_USB 13
+#define T830_GPIO_LED_WAN 4
+#define T830_GPIO_LED_WLAN 12
+
+#define T830_GPIO_BTN_RESET 17
+
+#define T830_KEYS_POLL_INTERVAL 20 /* msec */
+#define T830_KEYS_DEBOUNCE_INTERVAL (3 * T830_KEYS_POLL_INTERVAL)
+
+#define T830_WMAC_CALDATA_OFFSET 0x1000
+
+static struct gpio_led t830_gpio_leds[] __initdata = {
+ {
+ .name = "t830:green:lan1",
+ .gpio = T830_GPIO_LED_LAN1,
+ .active_low = 1,
+ }, {
+ .name = "t830:green:lan2",
+ .gpio = T830_GPIO_LED_LAN2,
+ .active_low = 1,
+ }, {
+ .name = "t830:green:lan3",
+ .gpio = T830_GPIO_LED_LAN3,
+ .active_low = 1,
+ }, {
+ .name = "t830:green:lan4",
+ .gpio = T830_GPIO_LED_LAN4,
+ .active_low = 1,
+ }, {
+ .name = "t830:green:usb",
+ .gpio = T830_GPIO_LED_USB,
+ .active_low = 1,
+ .default_state = LEDS_GPIO_DEFSTATE_KEEP,
+ }, {
+ .name = "t830:green:wan",
+ .gpio = T830_GPIO_LED_WAN,
+ .active_low = 1,
+ }, {
+ .name = "t830:green:wlan",
+ .gpio = T830_GPIO_LED_WLAN,
+ .active_low = 1,
+ },
+};
+
+static struct gpio_keys_button t830_gpio_keys[] __initdata = {
+ {
+ .desc = "reset",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = T830_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = T830_GPIO_BTN_RESET,
+ .active_low = 1,
+ },
+};
+
+static void __init t830_setup(void)
+{
+ u8 *art = (u8 *) KSEG1ADDR(0x1fff1000);
+ u8 *mac = (u8 *) KSEG1ADDR(0x1fff0000);
+
+ ath79_register_m25p80(NULL);
+
+ ath79_setup_ar933x_phy4_switch(false, false);
+
+ ath79_register_mdio(0, 0x0);
+
+ ath79_switch_data.phy4_mii_en = 1;
+ ath79_switch_data.phy_poll_mask |= BIT(4);
+
+ /* LAN */
+ ath79_eth1_data.duplex = DUPLEX_FULL;
+ ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_GMII;
+ ath79_init_mac(ath79_eth1_data.mac_addr, mac + 6, 0);
+ ath79_register_eth(1);
+
+ /* WAN */
+ ath79_eth0_data.duplex = DUPLEX_FULL;
+ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_MII;
+ ath79_eth0_data.phy_mask = BIT(4);
+ ath79_eth0_data.speed = SPEED_100;
+ ath79_init_mac(ath79_eth0_data.mac_addr, mac, 0);
+ ath79_register_eth(0);
+
+ ath79_gpio_function_setup(AR934X_GPIO_FUNC_JTAG_DISABLE,
+ AR934X_GPIO_FUNC_CLK_OBS4_EN);
+
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(t830_gpio_leds),
+ t830_gpio_leds);
+
+ ath79_register_gpio_keys_polled(-1, T830_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(t830_gpio_keys),
+ t830_gpio_keys);
+
+ ath79_register_usb();
+ ath79_register_wmac(art, NULL);
+}
+
+MIPS_MACHINE(ATH79_MACH_T830, "T830", "YunCore T830", t830_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index dd6fe75337..da98a811e1 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -223,6 +223,7 @@ enum ath79_mach_type {
ATH79_MACH_SMART_300, /* NC-LINK SMART-300 */
ATH79_MACH_SOM9331, /* OpenEmbed SOM9331 */
ATH79_MACH_SR3200, /* YunCore SR3200 */
+ ATH79_MACH_T830, /* YunCore T830 */
ATH79_MACH_TELLSTICK_ZNET_LITE, /* TellStick ZNet Lite */
ATH79_MACH_TEW_632BRP, /* TRENDnet TEW-632BRP */
ATH79_MACH_TEW_673GRU, /* TRENDnet TEW-673GRU */