aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/01_leds7
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ar71xx/base-files/etc/diag.sh3
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh3
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ar71xx/config-4.41
-rw-r--r--target/linux/ar71xx/config-4.91
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt10
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-t830.c127
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h1
-rw-r--r--target/linux/ar71xx/generic/config-default1
-rw-r--r--target/linux/ar71xx/image/generic.mk12
13 files changed, 169 insertions, 0 deletions
diff --git a/target/linux/ar71xx/base-files/etc/board.d/01_leds b/target/linux/ar71xx/base-files/etc/board.d/01_leds
index 24c71f2a3c..fa47461f64 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/01_leds
+++ b/target/linux/ar71xx/base-files/etc/board.d/01_leds
@@ -542,6 +542,7 @@ r36a)
ucidef_set_led_wlan "wlan" "WLAN" "$board:blue:wlan" "phy0tpt"
;;
r602n|\
+t830|\
zbt-we1526)
ucidef_set_led_netdev "wan" "WAN" "$board:green:wan" "eth1"
ucidef_set_led_switch "lan1" "LAN1" "$board:green:lan1" "switch0" "0x10"
@@ -549,6 +550,12 @@ zbt-we1526)
ucidef_set_led_switch "lan3" "LAN3" "$board:green:lan3" "switch0" "0x04"
ucidef_set_led_switch "lan4" "LAN4" "$board:green:lan4" "switch0" "0x02"
ucidef_set_led_wlan "wlan" "WLAN" "$board:green:wlan" "phy0tpt"
+
+ case "$board" in
+ t830)
+ ucidef_set_led_usbdev "usb" "USB" "$board:green:usb" "1-1"
+ ;;
+ esac
;;
r6100)
ucidef_set_led_netdev "wan" "WAN (green)" "netgear:green:wan" "eth0"
diff --git a/target/linux/ar71xx/base-files/etc/board.d/02_network b/target/linux/ar71xx/base-files/etc/board.d/02_network
index f4e113a814..6beb8fbfdb 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/02_network
+++ b/target/linux/ar71xx/base-files/etc/board.d/02_network
@@ -34,6 +34,7 @@ ar71xx_setup_interfaces()
rb-750|\
rb-751|\
som9331|\
+ t830|\
tew-632brp|\
tew-712br|\
tew-732br|\
diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
index f7f622d92b..41b6f09304 100644
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -388,6 +388,9 @@ get_status_led() {
qihoo-c301)
status_led="qihoo:green:status"
;;
+ t830)
+ status_led="$board:green:usb"
+ ;;
tellstick-znet-lite)
status_led="tellstick:white:system"
;;
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index 034a3a435b..a041255c90 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -1064,6 +1064,9 @@ ar71xx_board_detect() {
*"SR3200")
name="sr3200"
;;
+ *"T830")
+ name="t830"
+ ;;
*"TellStick ZNet Lite")
name="tellstick-znet-lite"
;;
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
index 2904535372..d7b4c63848 100755
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
@@ -276,6 +276,7 @@ platform_check_image() {
sc300m|\
sc450|\
sr3200|\
+ t830|\
tew-632brp|\
tew-712br|\
tew-732br|\
diff --git a/target/linux/ar71xx/config-4.4 b/target/linux/ar71xx/config-4.4
index e76dea4fb6..99e4419272 100644
--- a/target/linux/ar71xx/config-4.4
+++ b/target/linux/ar71xx/config-4.4
@@ -181,6 +181,7 @@ CONFIG_ATH79=y
# CONFIG_ATH79_MACH_SMART_300 is not set
# CONFIG_ATH79_MACH_SOM9331 is not set
# CONFIG_ATH79_MACH_SR3200 is not set
+# CONFIG_ATH79_MACH_T830 is not set
# CONFIG_ATH79_MACH_TELLSTICK_ZNET_LITE is not set
# CONFIG_ATH79_MACH_TEW_632BRP is not set
# CONFIG_ATH79_MACH_TEW_673GRU is not set
diff --git a/target/linux/ar71xx/config-4.9 b/target/linux/ar71xx/config-4.9
index 4b48ccb830..64603daada 100644
--- a/target/linux/ar71xx/config-4.9
+++ b/target/linux/ar71xx/config-4.9
@@ -179,6 +179,7 @@ CONFIG_ATH79=y
# CONFIG_ATH79_MACH_SMART_300 is not set
# CONFIG_ATH79_MACH_SOM9331 is not set
# CONFIG_ATH79_MACH_SR3200 is not set
+# CONFIG_ATH79_MACH_T830 is not set
# CONFIG_ATH79_MACH_TELLSTICK_ZNET_LITE is not set
# CONFIG_ATH79_MACH_TEW_632BRP is not set
# CONFIG_ATH79_MACH_TEW_673GRU is not set
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index da3cf63cef..7c0494bcc8 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -1129,6 +1129,16 @@ config ATH79_MACH_SMART_300
select ATH79_DEV_M25P80
select ATH79_DEV_WMAC
+config ATH79_MACH_T830
+ bool "YunCore T830 support"
+ select SOC_QCA953X
+ select ARH79_DEV_ETH
+ select ARH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+
config ATH79_MACH_TELLSTICK_ZNET_LITE
bool "TellStick ZNet Lite"
select SOC_AR933X
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index cea297af87..181e23a37a 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -190,6 +190,7 @@ obj-$(CONFIG_ATH79_MACH_SC450) += mach-sc450.o
obj-$(CONFIG_ATH79_MACH_SMART_300) += mach-smart-300.o
obj-$(CONFIG_ATH79_MACH_SOM9331) += mach-som9331.o
obj-$(CONFIG_ATH79_MACH_SR3200) += mach-sr3200.o
+obj-$(CONFIG_ATH79_MACH_T830) += mach-t830.o
obj-$(CONFIG_ATH79_MACH_TELLSTICK_ZNET_LITE) += mach-tellstick-znet-lite.o
obj-$(CONFIG_ATH79_MACH_TEW_632BRP) += mach-tew-632brp.o
obj-$(CONFIG_ATH79_MACH_TEW_673GRU) += mach-tew-673gru.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-t830.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-t830.c
new file mode 100644
index 0000000000..ffdb2ca533
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-t830.c
@@ -0,0 +1,127 @@
+/*
+ * YunCore T830 board support
+ *
+ * Copyright (C) 2018 Piotr Dymacz <pepe2k@gmail.com>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define T830_GPIO_LED_LAN1 16
+#define T830_GPIO_LED_LAN2 15
+#define T830_GPIO_LED_LAN3 14
+#define T830_GPIO_LED_LAN4 11
+#define T830_GPIO_LED_USB 13
+#define T830_GPIO_LED_WAN 4
+#define T830_GPIO_LED_WLAN 12
+
+#define T830_GPIO_BTN_RESET 17
+
+#define T830_KEYS_POLL_INTERVAL 20 /* msec */
+#define T830_KEYS_DEBOUNCE_INTERVAL (3 * T830_KEYS_POLL_INTERVAL)
+
+#define T830_WMAC_CALDATA_OFFSET 0x1000
+
+static struct gpio_led t830_gpio_leds[] __initdata = {
+ {
+ .name = "t830:green:lan1",
+ .gpio = T830_GPIO_LED_LAN1,
+ .active_low = 1,
+ }, {
+ .name = "t830:green:lan2",
+ .gpio = T830_GPIO_LED_LAN2,
+ .active_low = 1,
+ }, {
+ .name = "t830:green:lan3",
+ .gpio = T830_GPIO_LED_LAN3,
+ .active_low = 1,
+ }, {
+ .name = "t830:green:lan4",
+ .gpio = T830_GPIO_LED_LAN4,
+ .active_low = 1,
+ }, {
+ .name = "t830:green:usb",
+ .gpio = T830_GPIO_LED_USB,
+ .active_low = 1,
+ .default_state = LEDS_GPIO_DEFSTATE_KEEP,
+ }, {
+ .name = "t830:green:wan",
+ .gpio = T830_GPIO_LED_WAN,
+ .active_low = 1,
+ }, {
+ .name = "t830:green:wlan",
+ .gpio = T830_GPIO_LED_WLAN,
+ .active_low = 1,
+ },
+};
+
+static struct gpio_keys_button t830_gpio_keys[] __initdata = {
+ {
+ .desc = "reset",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = T830_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = T830_GPIO_BTN_RESET,
+ .active_low = 1,
+ },
+};
+
+static void __init t830_setup(void)
+{
+ u8 *art = (u8 *) KSEG1ADDR(0x1fff1000);
+ u8 *mac = (u8 *) KSEG1ADDR(0x1fff0000);
+
+ ath79_register_m25p80(NULL);
+
+ ath79_setup_ar933x_phy4_switch(false, false);
+
+ ath79_register_mdio(0, 0x0);
+
+ ath79_switch_data.phy4_mii_en = 1;
+ ath79_switch_data.phy_poll_mask |= BIT(4);
+
+ /* LAN */
+ ath79_eth1_data.duplex = DUPLEX_FULL;
+ ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_GMII;
+ ath79_init_mac(ath79_eth1_data.mac_addr, mac + 6, 0);
+ ath79_register_eth(1);
+
+ /* WAN */
+ ath79_eth0_data.duplex = DUPLEX_FULL;
+ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_MII;
+ ath79_eth0_data.phy_mask = BIT(4);
+ ath79_eth0_data.speed = SPEED_100;
+ ath79_init_mac(ath79_eth0_data.mac_addr, mac, 0);
+ ath79_register_eth(0);
+
+ ath79_gpio_function_setup(AR934X_GPIO_FUNC_JTAG_DISABLE,
+ AR934X_GPIO_FUNC_CLK_OBS4_EN);
+
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(t830_gpio_leds),
+ t830_gpio_leds);
+
+ ath79_register_gpio_keys_polled(-1, T830_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(t830_gpio_keys),
+ t830_gpio_keys);
+
+ ath79_register_usb();
+ ath79_register_wmac(art, NULL);
+}
+
+MIPS_MACHINE(ATH79_MACH_T830, "T830", "YunCore T830", t830_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index dd6fe75337..da98a811e1 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -223,6 +223,7 @@ enum ath79_mach_type {
ATH79_MACH_SMART_300, /* NC-LINK SMART-300 */
ATH79_MACH_SOM9331, /* OpenEmbed SOM9331 */
ATH79_MACH_SR3200, /* YunCore SR3200 */
+ ATH79_MACH_T830, /* YunCore T830 */
ATH79_MACH_TELLSTICK_ZNET_LITE, /* TellStick ZNet Lite */
ATH79_MACH_TEW_632BRP, /* TRENDnet TEW-632BRP */
ATH79_MACH_TEW_673GRU, /* TRENDnet TEW-673GRU */
diff --git a/target/linux/ar71xx/generic/config-default b/target/linux/ar71xx/generic/config-default
index bba1b63564..b3d2df7509 100644
--- a/target/linux/ar71xx/generic/config-default
+++ b/target/linux/ar71xx/generic/config-default
@@ -138,6 +138,7 @@ CONFIG_ATH79_MACH_SC450=y
CONFIG_ATH79_MACH_SMART_300=y
CONFIG_ATH79_MACH_SOM9331=y
CONFIG_ATH79_MACH_SR3200=y
+CONFIG_ATH79_MACH_T830=y
CONFIG_ATH79_MACH_TELLSTICK_ZNET_LITE=y
CONFIG_ATH79_MACH_TEW_673GRU=y
CONFIG_ATH79_MACH_TEW_732BR=y
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index f23c208caf..2158a9921a 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -910,6 +910,18 @@ define Device/xd3200
endef
TARGET_DEVICES += xd3200
+define Device/t830
+ DEVICE_TITLE := YunCore T830
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
+ BOARDNAME := T830
+ IMAGE_SIZE := 16000k
+ MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),16000k(firmware),64k(art)ro
+ SUPPORTED_DEVICES := t830
+ IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) |\
+ append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += t830
+
define Device/tellstick-znet-lite
$(Device/tplink-16mlzma)
DEVICE_TITLE := TellStick ZNet Lite