aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx/image/Makefile
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-18 13:14:28 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-21 11:56:35 +0200
commiteff0a0e39e48e4d1d40fc2262f1394d6d391a8c0 (patch)
treeb89261013e56a416c82bd79bf9e97e44b436cec2 /target/linux/apm821xx/image/Makefile
parenta2fee73e270305c4cb086055cc30e97f65e6f58b (diff)
downloadupstream-eff0a0e39e48e4d1d40fc2262f1394d6d391a8c0.tar.gz
upstream-eff0a0e39e48e4d1d40fc2262f1394d6d391a8c0.tar.bz2
upstream-eff0a0e39e48e4d1d40fc2262f1394d6d391a8c0.zip
apm821xx: derive DEVICE_DTS from device name
The DEVICE_DTS variable always matches the device definition name, just with "_" replaced by "-". Thus, create a DEVICE_DTS definition in Device/Default and drop all the individual statements. If necessary in the future, local DEVICE_DTS will still overwrite that default. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/apm821xx/image/Makefile')
-rw-r--r--target/linux/apm821xx/image/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index 1b7c466a44..2331947e33 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -87,6 +87,7 @@ define Device/Default
KERNEL_ENTRY := 0x00000000
KERNEL_LOADADDR := 0x00000000
DEVICE_DTS_DIR := ../dts
+ DEVICE_DTS = $(subst _,-,$(1))
SUPPORTED_DEVICES = $(subst _,$(comma),$(1))
endef