aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-18 13:14:28 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-21 11:56:35 +0200
commiteff0a0e39e48e4d1d40fc2262f1394d6d391a8c0 (patch)
treeb89261013e56a416c82bd79bf9e97e44b436cec2 /target/linux/apm821xx
parenta2fee73e270305c4cb086055cc30e97f65e6f58b (diff)
downloadupstream-eff0a0e39e48e4d1d40fc2262f1394d6d391a8c0.tar.gz
upstream-eff0a0e39e48e4d1d40fc2262f1394d6d391a8c0.tar.bz2
upstream-eff0a0e39e48e4d1d40fc2262f1394d6d391a8c0.zip
apm821xx: derive DEVICE_DTS from device name
The DEVICE_DTS variable always matches the device definition name, just with "_" replaced by "-". Thus, create a DEVICE_DTS definition in Device/Default and drop all the individual statements. If necessary in the future, local DEVICE_DTS will still overwrite that default. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/apm821xx')
-rw-r--r--target/linux/apm821xx/image/Makefile1
-rw-r--r--target/linux/apm821xx/image/nand.mk5
-rw-r--r--target/linux/apm821xx/image/sata.mk1
3 files changed, 1 insertions, 6 deletions
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index 1b7c466a44..2331947e33 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -87,6 +87,7 @@ define Device/Default
KERNEL_ENTRY := 0x00000000
KERNEL_LOADADDR := 0x00000000
DEVICE_DTS_DIR := ../dts
+ DEVICE_DTS = $(subst _,-,$(1))
SUPPORTED_DEVICES = $(subst _,$(comma),$(1))
endef
diff --git a/target/linux/apm821xx/image/nand.mk b/target/linux/apm821xx/image/nand.mk
index a7338e79a0..29a4be0189 100644
--- a/target/linux/apm821xx/image/nand.mk
+++ b/target/linux/apm821xx/image/nand.mk
@@ -29,7 +29,6 @@ define Device/meraki_mr24
DEVICE_MODEL := MR24
DEVICE_PACKAGES := kmod-spi-gpio -swconfig
BOARD_NAME := mr24
- DEVICE_DTS := meraki-mr24
IMAGES := sysupgrade.bin
DTB_SIZE := 64512
IMAGE_SIZE := 8191k
@@ -47,7 +46,6 @@ define Device/meraki_mx60
DEVICE_PACKAGES := kmod-spi-gpio kmod-usb-ledtrig-usbport kmod-usb-dwc2 \
kmod-usb-storage block-mount
BOARD_NAME := mx60
- DEVICE_DTS := meraki-mx60
BLOCKSIZE := 63k
IMAGES := sysupgrade.bin
DTB_SIZE := 64512
@@ -80,14 +78,12 @@ endef
define Device/netgear_wndap620
$(Device/netgear_wndap6x0)
DEVICE_MODEL := WNDAP620 (Premium Wireless-N)
- DEVICE_DTS := netgear-wndap620
endef
TARGET_DEVICES += netgear_wndap620
define Device/netgear_wndap660
$(Device/netgear_wndap6x0)
DEVICE_MODEL := WNDAP660 (Dual Radio Dual Band Wireless-N)
- DEVICE_DTS := netgear-wndap660
endef
TARGET_DEVICES += netgear_wndap660
@@ -100,7 +96,6 @@ define Device/netgear_wndr4700
kmod-nls-utf8 kmod-usb3 kmod-usb-dwc2 kmod-usb-storage \
partx-utils
BOARD_NAME := wndr4700
- DEVICE_DTS := netgear-wndr4700
PAGESIZE := 2048
SUBPAGESIZE := 512
BLOCKSIZE := 128k
diff --git a/target/linux/apm821xx/image/sata.mk b/target/linux/apm821xx/image/sata.mk
index 444b2441f0..6fe8324b93 100644
--- a/target/linux/apm821xx/image/sata.mk
+++ b/target/linux/apm821xx/image/sata.mk
@@ -7,7 +7,6 @@ define Device/wd_mybooklive
DEVICE_VENDOR := Western Digital
DEVICE_MODEL := My Book Live Series (Single + Duo)
DEVICE_PACKAGES := kmod-usb-dwc2 kmod-usb-ledtrig-usbport kmod-usb-storage kmod-fs-vfat wpad-basic
- DEVICE_DTS := wd-mybooklive
SUPPORTED_DEVICES += mbl wd,mybooklive-duo
BLOCKSIZE := 1k
DTB_SIZE := 16384