aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx/image/Makefile
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2017-12-17 14:59:59 +0100
committerMathias Kresin <dev@kresin.me>2017-12-21 01:05:16 +0100
commite6604fab514f92cf2851b043d751f690666c9e82 (patch)
treefef102910bdd5dbca1042a6de62018098b425eac /target/linux/apm821xx/image/Makefile
parent1adeecf0d3ab6ba4e485bd3ad0749711d8aabac8 (diff)
downloadupstream-e6604fab514f92cf2851b043d751f690666c9e82.tar.gz
upstream-e6604fab514f92cf2851b043d751f690666c9e82.tar.bz2
upstream-e6604fab514f92cf2851b043d751f690666c9e82.zip
apm821xx: align device names with vendor_device format
Currently, the device name handle does not include the manufacturer. This can make it hard do differentiate between products from different vendors that have the same product name. As the handle is used to derive the image name. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/apm821xx/image/Makefile')
-rw-r--r--target/linux/apm821xx/image/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index 6efd3886d2..3094c56706 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -66,7 +66,7 @@ define Build/MerakiNAND
@cp $@.new $@
endef
-define Device/mr24
+define Device/meraki_mr24
DEVICE_TITLE := Cisco Meraki MR24
DEVICE_PACKAGES := kmod-spi-gpio
BOARD_NAME := mr24
@@ -84,9 +84,9 @@ define Device/mr24
IMAGE/sysupgrade.tar := sysupgrade-tar
UBINIZE_OPTS := -E 5
endef
-TARGET_DEVICES += mr24
+TARGET_DEVICES += meraki_mr24
-define Device/mx60
+define Device/meraki_mx60
DEVICE_TITLE := Cisco Meraki MX60/MX60W
DEVICE_PACKAGES := kmod-spi-gpio kmod-usb-ledtrig-usbport kmod-usb-dwc2 \
kmod-usb-storage block-mount
@@ -109,7 +109,7 @@ define Device/mx60
IMAGE/sysupgrade.tar := sysupgrade-tar
UBINIZE_OPTS := -E 5
endef
-TARGET_DEVICES += mx60
+TARGET_DEVICES += meraki_mx60
define Build/create-uImage-dtb
# flat_dt target expect FIT image - which WNDR4700's uboot doesn't support
@@ -149,7 +149,7 @@ define Build/wndr4700-specialImage
rm -rf $@.fakerd
endef
-define Device/WNDR4700
+define Device/netgear_wndr4700
DEVICE_TITLE := Netgear Centria N900 WNDR4700/WNDR4720
DEVICE_PACKAGES := badblocks block-mount e2fsprogs \
kmod-dm kmod-fs-ext4 kmod-fs-vfat kmod-usb-ledtrig-usbport \
@@ -176,7 +176,7 @@ define Device/WNDR4700
NETGEAR_HW_ID := 29763875+128+256
UBINIZE_OPTS := -E 5
endef
-TARGET_DEVICES += WNDR4700
+TARGET_DEVICES += netgear_wndr4700
endif
@@ -222,22 +222,22 @@ define Device/MyBookLiveDefault
IMAGE/rootfs.img.gz := boot-script | boot-img | hdd-img | gzip
endef
-define Device/MyBookLiveSingle
+define Device/wd_mybooklive
$(Device/MyBookLiveDefault)
DEVICE_TITLE := Western Digital My Book Live
DEVICE_DTS := wd-mybooklive
endef
-TARGET_DEVICES += MyBookLiveSingle
+TARGET_DEVICES += wd_mybooklive
-define Device/MyBookLiveDuo
+define Device/wd_mybooklive-duo
$(Device/MyBookLiveDefault)
DEVICE_TITLE := Western Digital My Book Live Duo
DEVICE_PACKAGES := kmod-usb-dwc2 kmod-usb-ledtrig-usbport kmod-usb-storage kmod-fs-vfat wpad-mini
DEVICE_DTS := wd-mybooklive-duo
endef
-TARGET_DEVICES += MyBookLiveDuo
+TARGET_DEVICES += wd_mybooklive-duo
endif