aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx/image/Makefile
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2018-12-27 19:12:23 +0100
committerChristian Lamparter <chunkeey@gmail.com>2019-01-01 16:39:59 +0100
commit257de1b01f985a96a08ba26f2feb5cffec89b911 (patch)
treea33fb1f34771ff7cdcb00b8396189072124614da /target/linux/apm821xx/image/Makefile
parent7d009d8e6abbd9c58c886d0ed75aecb7f80dc7f0 (diff)
downloadupstream-257de1b01f985a96a08ba26f2feb5cffec89b911.tar.gz
upstream-257de1b01f985a96a08ba26f2feb5cffec89b911.tar.bz2
upstream-257de1b01f985a96a08ba26f2feb5cffec89b911.zip
apm821xx: sata: boot-part feature integration
This patch adds the boot-part feature to the apm82181 sata target. This makes it possible to configure the boot partition size with the generic CONFIG_TARGET_KERNEL_PARTSIZE symbol. Please note: For people using custom images: Just like with CONFIG_TARGET_ROOTFS_PARTSIZE changing the value can cause sysupgrade to repartition the device! Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/apm821xx/image/Makefile')
-rw-r--r--target/linux/apm821xx/image/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index 1f054ab5b9..60b1f78a3b 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -15,7 +15,9 @@ define Build/boot-img
$(CP) $(IMAGE_KERNEL).dtb $@.bootdir/boot/$(DEVICE_DTB)
$(CP) $(IMAGE_KERNEL) $@.bootdir/boot/uImage
- genext2fs --block-size $(BLOCKSIZE:%k=%Ki) --size-in-blocks $$((1024 * $(BOOT_SIZE))) --root $@.bootdir $@.boot
+ genext2fs --block-size $(BLOCKSIZE:%k=%Ki) \
+ --size-in-blocks $$((1024 * $(CONFIG_TARGET_KERNEL_PARTSIZE))) \
+ --root $@.bootdir $@.boot
# convert it to revision 1 - needed for u-boot ext2load
$(STAGING_DIR_HOST)/bin/tune2fs -O filetype $@.boot
@@ -49,7 +51,7 @@ define Build/export-dtb
endef
define Build/hdd-img
- ./mbl_gen_hdd_img.sh $@ $@.boot $(IMAGE_ROOTFS) $(BOOT_SIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
+ ./mbl_gen_hdd_img.sh $@ $@.boot $(IMAGE_ROOTFS) $(CONFIG_TARGET_KERNEL_PARTSIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
endef
define Build/MerakiAdd-dtb
@@ -230,7 +232,6 @@ define Device/wd_mybooklive
DTB_SIZE := 16384
KERNEL := kernel-bin | dtb | gzip | uImage gzip
KERNEL_INITRAMFS := kernel-bin | gzip | dtb | MuImage-initramfs gzip
- BOOT_SIZE := 8
IMAGES := factory.img.gz kernel.dtb sysupgrade.img.gz
ARTIFACTS := kernel.dtb
DEVICE_DTB := apollo3g.dtb