aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--config/Config-images.in1
-rw-r--r--target/linux/apm821xx/image/Makefile7
-rw-r--r--target/linux/apm821xx/sata/target.mk2
3 files changed, 6 insertions, 4 deletions
diff --git a/config/Config-images.in b/config/Config-images.in
index 6fa9a67cb6..245aed098b 100644
--- a/config/Config-images.in
+++ b/config/Config-images.in
@@ -269,6 +269,7 @@ menu "Target Images"
config TARGET_KERNEL_PARTSIZE
int "Kernel partition size (in MB)"
depends on GRUB_IMAGES || USES_BOOT_PART
+ default 8 if TARGET_apm821xx_sata
default 16
config TARGET_ROOTFS_PARTSIZE
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index 1f054ab5b9..60b1f78a3b 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -15,7 +15,9 @@ define Build/boot-img
$(CP) $(IMAGE_KERNEL).dtb $@.bootdir/boot/$(DEVICE_DTB)
$(CP) $(IMAGE_KERNEL) $@.bootdir/boot/uImage
- genext2fs --block-size $(BLOCKSIZE:%k=%Ki) --size-in-blocks $$((1024 * $(BOOT_SIZE))) --root $@.bootdir $@.boot
+ genext2fs --block-size $(BLOCKSIZE:%k=%Ki) \
+ --size-in-blocks $$((1024 * $(CONFIG_TARGET_KERNEL_PARTSIZE))) \
+ --root $@.bootdir $@.boot
# convert it to revision 1 - needed for u-boot ext2load
$(STAGING_DIR_HOST)/bin/tune2fs -O filetype $@.boot
@@ -49,7 +51,7 @@ define Build/export-dtb
endef
define Build/hdd-img
- ./mbl_gen_hdd_img.sh $@ $@.boot $(IMAGE_ROOTFS) $(BOOT_SIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
+ ./mbl_gen_hdd_img.sh $@ $@.boot $(IMAGE_ROOTFS) $(CONFIG_TARGET_KERNEL_PARTSIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
endef
define Build/MerakiAdd-dtb
@@ -230,7 +232,6 @@ define Device/wd_mybooklive
DTB_SIZE := 16384
KERNEL := kernel-bin | dtb | gzip | uImage gzip
KERNEL_INITRAMFS := kernel-bin | gzip | dtb | MuImage-initramfs gzip
- BOOT_SIZE := 8
IMAGES := factory.img.gz kernel.dtb sysupgrade.img.gz
ARTIFACTS := kernel.dtb
DEVICE_DTB := apollo3g.dtb
diff --git a/target/linux/apm821xx/sata/target.mk b/target/linux/apm821xx/sata/target.mk
index 84de4b2ea6..790746c480 100644
--- a/target/linux/apm821xx/sata/target.mk
+++ b/target/linux/apm821xx/sata/target.mk
@@ -1,5 +1,5 @@
BOARDNAME := Devices which boot from SATA (NAS)
-FEATURES += ext4 usb ramdisk squashfs rootfs-part
+FEATURES += ext4 usb ramdisk squashfs rootfs-part boot-part
DEFAULT_PACKAGES += badblocks block-mount e2fsprogs \
kmod-dm kmod-md-mod partx-utils mkf2fs f2fsck