aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/amazon/patches-3.3
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-12-05 00:19:40 +0000
committerJohn Crispin <john@openwrt.org>2014-12-05 00:19:40 +0000
commite6858f5f3f46e5aabc6ffc6255a5be245fddaffe (patch)
tree75f214ae3b1b69999f8faed73579c3163eeb2088 /target/linux/amazon/patches-3.3
parente1c6ddfd206f661cacad9eb79d3dec9d48e1f151 (diff)
downloadupstream-e6858f5f3f46e5aabc6ffc6255a5be245fddaffe.tar.gz
upstream-e6858f5f3f46e5aabc6ffc6255a5be245fddaffe.tar.bz2
upstream-e6858f5f3f46e5aabc6ffc6255a5be245fddaffe.zip
amazon: R.I.P.
its been broken for 2 1/2 years Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 43516
Diffstat (limited to 'target/linux/amazon/patches-3.3')
-rw-r--r--target/linux/amazon/patches-3.3/000-mips-bad-intctl.patch33
-rw-r--r--target/linux/amazon/patches-3.3/010-mips_clocksource_init_war.patch33
-rw-r--r--target/linux/amazon/patches-3.3/017-wdt-driver.patch10
-rw-r--r--target/linux/amazon/patches-3.3/100-board.patch53
-rw-r--r--target/linux/amazon/patches-3.3/130-mtd_drivers.patch7
-rw-r--r--target/linux/amazon/patches-3.3/140-net_drivers.patch9
-rw-r--r--target/linux/amazon/patches-3.3/150-serial_driver.patch7
-rw-r--r--target/linux/amazon/patches-3.3/160-cfi-swap.patch56
8 files changed, 0 insertions, 208 deletions
diff --git a/target/linux/amazon/patches-3.3/000-mips-bad-intctl.patch b/target/linux/amazon/patches-3.3/000-mips-bad-intctl.patch
deleted file mode 100644
index 0aa37780a8..0000000000
--- a/target/linux/amazon/patches-3.3/000-mips-bad-intctl.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- a/arch/mips/kernel/traps.c
-+++ b/arch/mips/kernel/traps.c
-@@ -1593,7 +1593,16 @@ void __cpuinit per_cpu_trap_init(void)
- if (cpu_has_mips_r2) {
- cp0_compare_irq_shift = CAUSEB_TI - CAUSEB_IP;
- cp0_compare_irq = (read_c0_intctl() >> INTCTLB_IPTI) & 7;
-+ if (!cp0_compare_irq)
-+ cp0_compare_irq = CP0_LEGACY_COMPARE_IRQ;
-+
- cp0_perfcount_irq = (read_c0_intctl() >> INTCTLB_IPPCI) & 7;
-+ if (!cp0_perfcount_irq)
-+ cp0_perfcount_irq = CP0_LEGACY_PERFCNT_IRQ;
-+
-+ if (arch_fixup_c0_irqs)
-+ arch_fixup_c0_irqs();
-+
- if (cp0_perfcount_irq == cp0_compare_irq)
- cp0_perfcount_irq = -1;
- } else {
---- a/arch/mips/include/asm/irq.h
-+++ b/arch/mips/include/asm/irq.h
-@@ -139,9 +139,11 @@ extern void free_irqno(unsigned int irq)
- * IE7. Since R2 their number has to be read from the c0_intctl register.
- */
- #define CP0_LEGACY_COMPARE_IRQ 7
-+#define CP0_LEGACY_PERFCNT_IRQ 7
-
- extern int cp0_compare_irq;
- extern int cp0_compare_irq_shift;
- extern int cp0_perfcount_irq;
-+extern void __weak arch_fixup_c0_irqs(void);
-
- #endif /* _ASM_IRQ_H */
diff --git a/target/linux/amazon/patches-3.3/010-mips_clocksource_init_war.patch b/target/linux/amazon/patches-3.3/010-mips_clocksource_init_war.patch
deleted file mode 100644
index 7078b37437..0000000000
--- a/target/linux/amazon/patches-3.3/010-mips_clocksource_init_war.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- a/arch/mips/kernel/cevt-r4k.c
-+++ b/arch/mips/kernel/cevt-r4k.c
-@@ -23,6 +23,22 @@
-
- #ifndef CONFIG_MIPS_MT_SMTC
-
-+/*
-+ * Compare interrupt can be routed and latched outside the core,
-+ * so a single execution hazard barrier may not be enough to give
-+ * it time to clear as seen in the Cause register. 4 time the
-+ * pipeline depth seems reasonably conservative, and empirically
-+ * works better in configurations with high CPU/bus clock ratios.
-+ */
-+
-+#define compare_change_hazard() \
-+ do { \
-+ irq_disable_hazard(); \
-+ irq_disable_hazard(); \
-+ irq_disable_hazard(); \
-+ irq_disable_hazard(); \
-+ } while (0)
-+
- static int mips_next_event(unsigned long delta,
- struct clock_event_device *evt)
- {
-@@ -32,6 +48,7 @@ static int mips_next_event(unsigned long
- cnt = read_c0_count();
- cnt += delta;
- write_c0_compare(cnt);
-+ compare_change_hazard();
- res = ((int)(read_c0_count() - cnt) >= 0) ? -ETIME : 0;
- return res;
- }
diff --git a/target/linux/amazon/patches-3.3/017-wdt-driver.patch b/target/linux/amazon/patches-3.3/017-wdt-driver.patch
deleted file mode 100644
index 005ee710ac..0000000000
--- a/target/linux/amazon/patches-3.3/017-wdt-driver.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/drivers/watchdog/Makefile
-+++ b/drivers/watchdog/Makefile
-@@ -132,6 +132,7 @@ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
- obj-$(CONFIG_OCTEON_WDT) += octeon-wdt.o
- octeon-wdt-y := octeon-wdt-main.o octeon-wdt-nmi.o
- obj-$(CONFIG_LANTIQ_WDT) += lantiq_wdt.o
-+obj-$(CONFIG_AMAZON_WDT) += amazon_wdt.o
-
- # PARISC Architecture
-
diff --git a/target/linux/amazon/patches-3.3/100-board.patch b/target/linux/amazon/patches-3.3/100-board.patch
deleted file mode 100644
index b743052731..0000000000
--- a/target/linux/amazon/patches-3.3/100-board.patch
+++ /dev/null
@@ -1,53 +0,0 @@
---- a/arch/mips/Kconfig
-+++ b/arch/mips/Kconfig
-@@ -120,6 +120,22 @@ config BCM63XX
- help
- Support for BCM63XX based boards
-
-+config AMAZON
-+ bool "Amazon support (EXPERIMENTAL)"
-+ depends on EXPERIMENTAL
-+ select DMA_NONCOHERENT
-+ select IRQ_CPU
-+ select CEVT_R4K
-+ select CSRC_R4K
-+ select SYS_HAS_CPU_MIPS32_R1
-+ select SYS_HAS_CPU_MIPS32_R2
-+ select HAVE_STD_PC_SERIAL_PORT
-+ select SYS_SUPPORTS_BIG_ENDIAN
-+ select SYS_SUPPORTS_32BIT_KERNEL
-+ select SYS_HAS_EARLY_PRINTK
-+ select HW_HAS_PCI
-+ select SWAP_IO_SPACE
-+
- config MIPS_COBALT
- bool "Cobalt Server"
- select CEVT_R4K
-@@ -813,6 +829,7 @@ config NLM_XLP_BOARD
-
- endchoice
-
-+source "arch/mips/amazon/Kconfig"
- source "arch/mips/alchemy/Kconfig"
- source "arch/mips/ath79/Kconfig"
- source "arch/mips/bcm47xx/Kconfig"
---- a/arch/mips/Kbuild.platforms
-+++ b/arch/mips/Kbuild.platforms
-@@ -6,6 +6,7 @@ platforms += ath79
- platforms += bcm47xx
- platforms += bcm63xx
- platforms += cavium-octeon
-+platforms += amazon
- platforms += cobalt
- platforms += dec
- platforms += emma
---- /dev/null
-+++ b/arch/mips/amazon/Platform
-@@ -0,0 +1,7 @@
-+#
-+# Infineon AMAZON boards
-+#
-+platform-$(CONFIG_AMAZON) += amazon/
-+cflags-$(CONFIG_AMAZON) += \
-+ -I$(srctree)/arch/mips/include/asm/mach-amazon
-+load-$(CONFIG_AMAZON) := 0xffffffff80002000
diff --git a/target/linux/amazon/patches-3.3/130-mtd_drivers.patch b/target/linux/amazon/patches-3.3/130-mtd_drivers.patch
deleted file mode 100644
index 6ce28e3fdd..0000000000
--- a/target/linux/amazon/patches-3.3/130-mtd_drivers.patch
+++ /dev/null
@@ -1,7 +0,0 @@
---- a/drivers/mtd/maps/Makefile
-+++ b/drivers/mtd/maps/Makefile
-@@ -57,3 +57,4 @@ obj-$(CONFIG_MTD_VMU) += vmu-flash.o
- obj-$(CONFIG_MTD_GPIO_ADDR) += gpio-addr-flash.o
- obj-$(CONFIG_MTD_LATCH_ADDR) += latch-addr-flash.o
- obj-$(CONFIG_MTD_LANTIQ) += lantiq-flash.o
-+obj-$(CONFIG_AMAZON_MTD) += amazon.o
diff --git a/target/linux/amazon/patches-3.3/140-net_drivers.patch b/target/linux/amazon/patches-3.3/140-net_drivers.patch
deleted file mode 100644
index 9c840e67f9..0000000000
--- a/target/linux/amazon/patches-3.3/140-net_drivers.patch
+++ /dev/null
@@ -1,9 +0,0 @@
---- a/drivers/net/ethernet/Makefile
-+++ b/drivers/net/ethernet/Makefile
-@@ -74,3 +74,6 @@ obj-$(CONFIG_NET_VENDOR_TUNDRA) += tundr
- obj-$(CONFIG_NET_VENDOR_VIA) += via/
- obj-$(CONFIG_NET_VENDOR_XILINX) += xilinx/
- obj-$(CONFIG_NET_VENDOR_XIRCOM) += xircom/
-+
-+obj-$(CONFIG_AMAZON_NET_SW) += amazon_sw.o
-+obj-$(CONFIG_ADM6996_SUPPORT) += admmod.o
diff --git a/target/linux/amazon/patches-3.3/150-serial_driver.patch b/target/linux/amazon/patches-3.3/150-serial_driver.patch
deleted file mode 100644
index c6e7f39bd4..0000000000
--- a/target/linux/amazon/patches-3.3/150-serial_driver.patch
+++ /dev/null
@@ -1,7 +0,0 @@
---- a/drivers/tty/serial/Makefile
-+++ b/drivers/tty/serial/Makefile
-@@ -78,3 +78,4 @@ obj-$(CONFIG_SERIAL_LANTIQ) += lantiq.o
- obj-$(CONFIG_SERIAL_XILINX_PS_UART) += xilinx_uartps.o
- obj-$(CONFIG_SERIAL_SIRFSOC) += sirfsoc_uart.o
- obj-$(CONFIG_SERIAL_AR933X) += ar933x_uart.o
-+obj-$(CONFIG_AMAZON_ASC_UART) += amazon_asc.o
diff --git a/target/linux/amazon/patches-3.3/160-cfi-swap.patch b/target/linux/amazon/patches-3.3/160-cfi-swap.patch
deleted file mode 100644
index 4a0009e432..0000000000
--- a/target/linux/amazon/patches-3.3/160-cfi-swap.patch
+++ /dev/null
@@ -1,56 +0,0 @@
---- a/drivers/mtd/chips/cfi_cmdset_0002.c
-+++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -1152,6 +1152,9 @@ static int __xipram do_write_oneword(str
- int retry_cnt = 0;
-
- adr += chip->start;
-+#ifdef CONFIG_AMAZON
-+ adr ^= 2;
-+#endif
-
- mutex_lock(&chip->mutex);
- ret = get_chip(map, chip, adr, FL_WRITING);
-@@ -1420,7 +1423,11 @@ static int __xipram do_write_buffer(stru
- z = 0;
- while(z < words * map_bankwidth(map)) {
- datum = map_word_load(map, buf);
-+#ifdef CONFIG_AMAZON
-+ map_write(map, datum, (adr + z) ^ 0x2);
-+#else
- map_write(map, datum, adr + z);
-+#endif
-
- z += map_bankwidth(map);
- buf += map_bankwidth(map);
-@@ -1665,6 +1672,9 @@ static int __xipram do_erase_oneblock(st
- int ret = 0;
-
- adr += chip->start;
-+#ifdef CONFIG_AMAZON
-+ adr ^= 2;
-+#endif
-
- mutex_lock(&chip->mutex);
- ret = get_chip(map, chip, adr, FL_ERASING);
-@@ -1793,6 +1803,10 @@ static int do_atmel_lock(struct map_info
- struct cfi_private *cfi = map->fldrv_priv;
- int ret;
-
-+#ifdef CONFIG_AMAZON
-+ adr ^= 2;
-+#endif
-+
- mutex_lock(&chip->mutex);
- ret = get_chip(map, chip, adr + chip->start, FL_LOCKING);
- if (ret)
-@@ -1828,6 +1842,10 @@ static int do_atmel_unlock(struct map_in
- struct cfi_private *cfi = map->fldrv_priv;
- int ret;
-
-+#ifdef CONFIG_AMAZON
-+ adr ^= 2;
-+#endif
-+
- mutex_lock(&chip->mutex);
- ret = get_chip(map, chip, adr + chip->start, FL_UNLOCKING);
- if (ret)