aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/airoha/image
diff options
context:
space:
mode:
authorDaniel Danzberger <daniel@dd-wrt.com>2022-08-03 17:31:03 +0200
committerFelix Fietkau <nbd@nbd.name>2022-09-05 11:12:32 +0200
commitf32085fc0b87049491b07e198d924d738a1a2834 (patch)
tree5383b5ef246e08830738801a12a6e8dc76b39c53 /target/linux/airoha/image
parentf1802b0db7e22f98e1718e2c8bec29b2842f5aea (diff)
downloadupstream-f32085fc0b87049491b07e198d924d738a1a2834.tar.gz
upstream-f32085fc0b87049491b07e198d924d738a1a2834.tar.bz2
upstream-f32085fc0b87049491b07e198d924d738a1a2834.zip
airoha: Add new target platform
Airoha is a new ARM platform based on Cortex-A53 which has recently been merged into linux-next. Due to BootROM limitations on this platform, the Cortex-A53 can't run in Aarch64 mode and code must be compiled for 32-Bit ARM. This support is based mostly on those linux-next commits backported for kernel 5.15. Patches: 1 - platform support = linux-next 2 - clock driver = linux-next 3 - gpio driver = linux-next 4 - linux,usable-memory-range dts support = linux-next 5 - mtd spinand driver 6 - spi driver 7 - pci driver (kconfig only, uses mediatek PCI) = linux-next Still missing: - Ethernet driver - Sysupgrade support A.t.m there exists one subtarget EN7523 with only one evaluation board. The initramfs can be run with the following commands from u-boot: - u-boot> setenv bootfile \ openwrt-airoha-airoha_en7523-evb-initramfs-kernel.bin u-boot> tftpboot u-boot> bootm 0x81800000 - Signed-off-by: Daniel Danzberger <daniel@dd-wrt.com>
Diffstat (limited to 'target/linux/airoha/image')
-rw-r--r--target/linux/airoha/image/Makefile37
-rw-r--r--target/linux/airoha/image/en7523.mk0
2 files changed, 37 insertions, 0 deletions
diff --git a/target/linux/airoha/image/Makefile b/target/linux/airoha/image/Makefile
new file mode 100644
index 0000000000..c6def5ad65
--- /dev/null
+++ b/target/linux/airoha/image/Makefile
@@ -0,0 +1,37 @@
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+KERNEL_LOADADDR := 0x80208000
+
+define Target/Description
+ Build firmware images for Airoha EN7523 ARM based boards.
+endef
+
+# default all platform image(fit) build
+define Device/Default
+ PROFILES = Default $$(DEVICE_NAME)
+ KERNEL_NAME := Image
+ KERNEL = kernel-bin | lzma | \
+ fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
+ KERNEL_INITRAMFS = kernel-bin | lzma | \
+ fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb with-initrd
+ FILESYSTEMS := squashfs
+ DEVICE_DTS_DIR := $(DTS_DIR)
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin := append-kernel | pad-to 128k | append-rootfs | \
+ pad-rootfs | append-metadata
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+define Device/airoha_en7523-evb
+ DEVICE_VENDOR := Airoha
+ DEVICE_MODEL := EN7523 Evaluation Board
+ DEVICE_DTS := en7523-evb
+ DEVICE_DTS_DIR := ../dts
+endef
+TARGET_DEVICES += airoha_en7523-evb
+
+$(eval $(call BuildImage))
diff --git a/target/linux/airoha/image/en7523.mk b/target/linux/airoha/image/en7523.mk
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/target/linux/airoha/image/en7523.mk