aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/airoha/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/airoha/image/Makefile')
-rw-r--r--target/linux/airoha/image/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/target/linux/airoha/image/Makefile b/target/linux/airoha/image/Makefile
new file mode 100644
index 0000000000..c6def5ad65
--- /dev/null
+++ b/target/linux/airoha/image/Makefile
@@ -0,0 +1,37 @@
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+KERNEL_LOADADDR := 0x80208000
+
+define Target/Description
+ Build firmware images for Airoha EN7523 ARM based boards.
+endef
+
+# default all platform image(fit) build
+define Device/Default
+ PROFILES = Default $$(DEVICE_NAME)
+ KERNEL_NAME := Image
+ KERNEL = kernel-bin | lzma | \
+ fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
+ KERNEL_INITRAMFS = kernel-bin | lzma | \
+ fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb with-initrd
+ FILESYSTEMS := squashfs
+ DEVICE_DTS_DIR := $(DTS_DIR)
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin := append-kernel | pad-to 128k | append-rootfs | \
+ pad-rootfs | append-metadata
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+define Device/airoha_en7523-evb
+ DEVICE_VENDOR := Airoha
+ DEVICE_MODEL := EN7523 Evaluation Board
+ DEVICE_DTS := en7523-evb
+ DEVICE_DTS_DIR := ../dts
+endef
+TARGET_DEVICES += airoha_en7523-evb
+
+$(eval $(call BuildImage))