aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2017-06-17 01:24:43 +0200
committerDaniel Golle <daniel@makrotopia.org>2017-06-17 01:24:43 +0200
commitd80d1b6c42aa663e6104f817daa5ea29d2e7073d (patch)
tree75eb2aac07bd14cd6787009ae1f7fe79c99b758e /target/imagebuilder
parent1b555e1d2b1cb2ae3dd1832225e6c9d2c5df0a37 (diff)
downloadupstream-d80d1b6c42aa663e6104f817daa5ea29d2e7073d.tar.gz
upstream-d80d1b6c42aa663e6104f817daa5ea29d2e7073d.tar.bz2
upstream-d80d1b6c42aa663e6104f817daa5ea29d2e7073d.zip
imagebuilder: don't rewrite package list output
No longer rewrite opkg list output in package_list function, remove the awk call in the pipe (which was intended for a single specific use-case). Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/files/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index d2afd0e844..95f405b8fd 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -140,7 +140,7 @@ package_reload:
package_list: FORCE
@$(MAKE) -s package_reload
- @$(OPKG) list --size 2>/dev/null | awk -F" - " '{printf "%s %s %s\n", $$1, $$2, $$3}'
+ @$(OPKG) list --size 2>/dev/null
package_install: FORCE
@echo