aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2017-06-17 00:54:46 +0200
committerDaniel Golle <daniel@makrotopia.org>2017-06-17 00:54:46 +0200
commit1b555e1d2b1cb2ae3dd1832225e6c9d2c5df0a37 (patch)
treefcbbb140bbcb3975da1943508afcac0470420d0f /target/imagebuilder
parent76b62e602233d1a2e1f8ef1c0833bd22ebaaf832 (diff)
downloadupstream-1b555e1d2b1cb2ae3dd1832225e6c9d2c5df0a37.tar.gz
upstream-1b555e1d2b1cb2ae3dd1832225e6c9d2c5df0a37.tar.bz2
upstream-1b555e1d2b1cb2ae3dd1832225e6c9d2c5df0a37.zip
imagebuilder: clean package_list
commit 19ac879954 (imagebuilder: add package_list function) introduced a new function 'package_list' to the imagebuilder Makefile. Unfortunately the package list was poluted by stdout noise of the Makefile itself as well as opkg. Redirect those outputs to stderr to make sure that the package_list returned doesn't contain progress info output but really only packages. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/files/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index f8702b5861..d2afd0e844 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -78,7 +78,7 @@ PROFILE_LIST = $(foreach p,$(PROFILE_NAMES), \
)
.profiles.mk: .targetinfo
- $(SCRIPT_DIR)/target-metadata.pl profile_mk $< '$(BOARD)$(if $(SUBTARGET),/$(SUBTARGET))' > $@
+ @$(SCRIPT_DIR)/target-metadata.pl profile_mk $< '$(BOARD)$(if $(SUBTARGET),/$(SUBTARGET))' > $@
staging_dir/host/.prereq-build: include/prereq-build.mk
mkdir -p tmp
@@ -121,21 +121,21 @@ endif
$(MAKE) -s checksum
package_index: FORCE
- @echo
- @echo Building package index...
+ @echo >&2
+ @echo Building package index... >&2
@mkdir -p $(TMP_DIR) $(TARGET_DIR)/tmp
(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages && \
gzip -9nc Packages > Packages.gz \
) >/dev/null 2>/dev/null
- $(OPKG) update || true
+ $(OPKG) update >&2 || true
package_reload:
if [ ! -f "$(PACKAGE_DIR)/Packages" ] || [ ! -f "$(PACKAGE_DIR)/Packages.gz" ] || [ "`find $(PACKAGE_DIR) -cnewer $(PACKAGE_DIR)/Packages.gz`" ]; then \
- echo "Package list missing or not up-to-date, generating it.";\
+ echo "Package list missing or not up-to-date, generating it." >&2 ;\
$(MAKE) package_index; \
else \
mkdir -p $(TARGET_DIR)/tmp; \
- $(OPKG) update || true; \
+ $(OPKG) update >&2 || true; \
fi
package_list: FORCE