aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-13 19:22:09 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-13 19:46:45 +0100
commit619c8fa92209fb1a30d6e68a59a13aaa102a764c (patch)
treefc847d9f8b3a0e20901137ea55e3661072a376b8 /target/imagebuilder
parentd1514e8f846ae629614abea7dc4611437698adfe (diff)
downloadupstream-619c8fa92209fb1a30d6e68a59a13aaa102a764c.tar.gz
upstream-619c8fa92209fb1a30d6e68a59a13aaa102a764c.tar.bz2
upstream-619c8fa92209fb1a30d6e68a59a13aaa102a764c.zip
imagebuilder: remove existing debug kernel image
Reduces tarball size and improves build time Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index 13eed7e108..d891aab18c 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -67,6 +67,7 @@ endif
-cp $(KERNEL_BUILD_DIR)/* $(IB_KDIR)/ # don't copy subdirectories here
-cp $(LINUX_DIR)/.config $(IB_LDIR)/
rm -f $(IB_KDIR)/root.*
+ rm -f $(IB_KDIR)/vmlinux.debug
if [ -x $(LINUX_DIR)/scripts/dtc/dtc ]; then \
$(INSTALL_DIR) $(IB_LDIR)/scripts/dtc; \
$(INSTALL_BIN) $(LINUX_DIR)/scripts/dtc/dtc $(IB_LDIR)/scripts/dtc/dtc; \