aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-13 19:21:31 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-13 19:46:45 +0100
commitd1514e8f846ae629614abea7dc4611437698adfe (patch)
tree806adc79ff93e84e55b5d84324244def87d9fd3a /target/imagebuilder
parentc6a8a23ea2ed4e92f8e96d783fb672d167cfb611 (diff)
downloadupstream-d1514e8f846ae629614abea7dc4611437698adfe.tar.gz
upstream-d1514e8f846ae629614abea7dc4611437698adfe.tar.bz2
upstream-d1514e8f846ae629614abea7dc4611437698adfe.zip
imagebuilder: remove existing root filesystem images
Reduces tarball size and improves build time Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index 8a7c2093b9..13eed7e108 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -66,6 +66,7 @@ endif
$(PKG_BUILD_DIR)/target/linux/*/patches{,-*}
-cp $(KERNEL_BUILD_DIR)/* $(IB_KDIR)/ # don't copy subdirectories here
-cp $(LINUX_DIR)/.config $(IB_LDIR)/
+ rm -f $(IB_KDIR)/root.*
if [ -x $(LINUX_DIR)/scripts/dtc/dtc ]; then \
$(INSTALL_DIR) $(IB_LDIR)/scripts/dtc; \
$(INSTALL_BIN) $(LINUX_DIR)/scripts/dtc/dtc $(IB_LDIR)/scripts/dtc/dtc; \