aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/timestamp.pl
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-08-29 03:51:49 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-08-29 03:51:49 +0000
commitd475d94aab91230bd837a9d4d7ea58c3829e1c20 (patch)
tree2e9dfad5563ba1e590208621984e77cd6853b9af /scripts/timestamp.pl
parentec70a7a19f472cca7f657ba96f3fcdeb2dd90198 (diff)
downloadupstream-d475d94aab91230bd837a9d4d7ea58c3829e1c20.tar.gz
upstream-d475d94aab91230bd837a9d4d7ea58c3829e1c20.tar.bz2
upstream-d475d94aab91230bd837a9d4d7ea58c3829e1c20.zip
avoid rdep in the top level make process (subdir.mk) - it leaks too much memory and increases the startup time for regular make commands. timestamp.pl is more lightweight here
SVN-Revision: 8533
Diffstat (limited to 'scripts/timestamp.pl')
-rwxr-xr-xscripts/timestamp.pl7
1 files changed, 6 insertions, 1 deletions
diff --git a/scripts/timestamp.pl b/scripts/timestamp.pl
index a4c5cae015..89ec4e70c3 100755
--- a/scripts/timestamp.pl
+++ b/scripts/timestamp.pl
@@ -39,6 +39,9 @@ while (@ARGV > 0) {
$options{"findopts"} .= " -and -not -path \\*".$str."\\*"
} elsif ($path =~ /^-f/) {
$options{"findopts"} .= " -follow";
+ } elsif ($path =~ /^-n/) {
+ my $arg = $ARGV[0];
+ $options{$path} = $arg;
} elsif ($path =~ /^-/) {
$options{$path} = 1;
} else {
@@ -54,7 +57,9 @@ while (@ARGV > 0) {
}
}
-if ($options{"-p"}) {
+if ($options{"-n"}) {
+ exit ($n eq $options{"-n"} ? 0 : 1);
+} elsif ($options{"-p"}) {
print "$n\n";
} elsif ($options{"-t"}) {
print "$ts\n";