aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-08-29 03:51:49 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-08-29 03:51:49 +0000
commitd475d94aab91230bd837a9d4d7ea58c3829e1c20 (patch)
tree2e9dfad5563ba1e590208621984e77cd6853b9af
parentec70a7a19f472cca7f657ba96f3fcdeb2dd90198 (diff)
downloadupstream-d475d94aab91230bd837a9d4d7ea58c3829e1c20.tar.gz
upstream-d475d94aab91230bd837a9d4d7ea58c3829e1c20.tar.bz2
upstream-d475d94aab91230bd837a9d4d7ea58c3829e1c20.zip
avoid rdep in the top level make process (subdir.mk) - it leaks too much memory and increases the startup time for regular make commands. timestamp.pl is more lightweight here
SVN-Revision: 8533
-rw-r--r--include/subdir.mk10
-rwxr-xr-xscripts/timestamp.pl7
2 files changed, 9 insertions, 8 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index 217d6bc376..0a3eff307e 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -37,13 +37,9 @@ endef
# Parameters: <subdir> <name> <target>
define stampfile
$(1)/stamp-$(3):=$(STAGING_DIR)/stamp/.$(2)_$(3)
- $(if $(__rdep_$(1)),,
- $(call rdep,$(1),$$($(1)/stamp-$(3)),)
- __rdep_$(1):=1
- )
-
- $$($(1)/stamp-$(3)):
- @+$(MAKE) $$($(1)/flags-$(3)) $(1)/$(3)
+ $$($(1)/stamp-$(3)): $(TMP_DIR)/.build
+ @+$(SCRIPT_DIR)/timestamp.pl -n $$($(1)/stamp-$(3)) $(1) || \
+ $(MAKE) $$($(1)/flags-$(3)) $(1)/$(3)
@mkdir -p $$$$(dirname $$($(1)/stamp-$(3)))
@touch $$($(1)/stamp-$(3))
diff --git a/scripts/timestamp.pl b/scripts/timestamp.pl
index a4c5cae015..89ec4e70c3 100755
--- a/scripts/timestamp.pl
+++ b/scripts/timestamp.pl
@@ -39,6 +39,9 @@ while (@ARGV > 0) {
$options{"findopts"} .= " -and -not -path \\*".$str."\\*"
} elsif ($path =~ /^-f/) {
$options{"findopts"} .= " -follow";
+ } elsif ($path =~ /^-n/) {
+ my $arg = $ARGV[0];
+ $options{$path} = $arg;
} elsif ($path =~ /^-/) {
$options{$path} = 1;
} else {
@@ -54,7 +57,9 @@ while (@ARGV > 0) {
}
}
-if ($options{"-p"}) {
+if ($options{"-n"}) {
+ exit ($n eq $options{"-n"} ? 0 : 1);
+} elsif ($options{"-p"}) {
print "$n\n";
} elsif ($options{"-t"}) {
print "$ts\n";