aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/ipkg-make-index.sh
diff options
context:
space:
mode:
authorAlberto Bursi <alberto.bursi@outlook.it>2016-12-24 13:32:26 +0100
committerFelix Fietkau <nbd@nbd.name>2016-12-26 11:17:33 +0100
commitc24172cad1e66412b287cf49809d363e10acb1c5 (patch)
treec039f023ffe56dfac099410997c479dedac4a0fe /scripts/ipkg-make-index.sh
parent4c4047ec19edcaf39ec83728904d1081bf848894 (diff)
downloadupstream-c24172cad1e66412b287cf49809d363e10acb1c5.tar.gz
upstream-c24172cad1e66412b287cf49809d363e10acb1c5.tar.bz2
upstream-c24172cad1e66412b287cf49809d363e10acb1c5.zip
package/Makefile & ipkg-make-index.sh: add full package data list
The external script used to generate the package lists for the LEDE wiki's table of packages [1] and package indexes [2] requires a "Source:" field in the package lists to find package makefiles. The package makefiles are used to read the package's Category and Submenu. The "Source:" field was removed in commit b4aa3c899cbf1f81cd8a1ea197481ac84a9d646e to reduce package list sizes and lessen opkg issues in low ram devices. Add a separate package list file with full data to be used by the wiki's script. It's called Packages.manifest and isn't compressed as it's not necessary. 1. https://lede-project.org/packages/start 2. https://lede-project.org/packages/index/start Signed-off-by: Alberto Bursi <alberto.bursi@outlook.it>
Diffstat (limited to 'scripts/ipkg-make-index.sh')
-rwxr-xr-xscripts/ipkg-make-index.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/ipkg-make-index.sh b/scripts/ipkg-make-index.sh
index ac6f9837bc..c99c5fe8a3 100755
--- a/scripts/ipkg-make-index.sh
+++ b/scripts/ipkg-make-index.sh
@@ -24,7 +24,7 @@ for pkg in `find $pkg_dir -name '*.ipk' | sort`; do
tar -xzOf $pkg ./control.tar.gz | tar xzOf - ./control | sed -e "s/^Description:/Filename: $sed_safe_pkg\\
Size: $file_size\\
SHA256sum: $sha256sum\\
-Description:/" | grep -vE '^(Maintainer|LicenseFiles|Source|Require)'
+Description:/"
echo ""
done
[ -n "$empty" ] && echo