aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/Makefile3
-rwxr-xr-xscripts/ipkg-make-index.sh2
2 files changed, 3 insertions, 2 deletions
diff --git a/package/Makefile b/package/Makefile
index 64efeb3745..17378a95ef 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -88,7 +88,8 @@ $(curdir)/index: FORCE
@for d in $(PACKAGE_SUBDIRS); do ( \
mkdir -p $$d; \
cd $$d || continue; \
- $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages && \
+ $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages.manifest; \
+ grep -vE '^(Maintainer|LicenseFiles|Source|Require)' Packages.manifest > Packages && \
gzip -9nc Packages > Packages.gz; \
); done
ifdef CONFIG_SIGNED_PACKAGES
diff --git a/scripts/ipkg-make-index.sh b/scripts/ipkg-make-index.sh
index ac6f9837bc..c99c5fe8a3 100755
--- a/scripts/ipkg-make-index.sh
+++ b/scripts/ipkg-make-index.sh
@@ -24,7 +24,7 @@ for pkg in `find $pkg_dir -name '*.ipk' | sort`; do
tar -xzOf $pkg ./control.tar.gz | tar xzOf - ./control | sed -e "s/^Description:/Filename: $sed_safe_pkg\\
Size: $file_size\\
SHA256sum: $sha256sum\\
-Description:/" | grep -vE '^(Maintainer|LicenseFiles|Source|Require)'
+Description:/"
echo ""
done
[ -n "$empty" ] && echo