aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-09-19 12:03:30 -0700
committerJohn Crispin <john@phrozen.org>2018-10-11 08:06:28 +0200
commitc7144ec688192c83ec91c4a4ff4f5db06c11e469 (patch)
tree50ffd6e0d05553f9992a2cf0713231a977069ae1 /package
parentf5ddbd695bcfb8ae8f8c681767beb6ee9770695d (diff)
downloadupstream-c7144ec688192c83ec91c4a4ff4f5db06c11e469.tar.gz
upstream-c7144ec688192c83ec91c4a4ff4f5db06c11e469.tar.bz2
upstream-c7144ec688192c83ec91c4a4ff4f5db06c11e469.zip
comgt: Install hotplug and netifd files as 600
procd and netifd both run as root. These files are not used elsewhere. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/comgt/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/network/utils/comgt/Makefile b/package/network/utils/comgt/Makefile
index 3b7f4b9022..d4d673e783 100644
--- a/package/network/utils/comgt/Makefile
+++ b/package/network/utils/comgt/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=comgt
PKG_VERSION:=0.32
-PKG_RELEASE:=30
+PKG_RELEASE:=31
PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
PKG_SOURCE_URL:=@SF/comgt
@@ -80,9 +80,9 @@ define Package/comgt/install
$(INSTALL_DATA) ./files/getcnum.gcom $(1)/etc/gcom/getcnum.gcom
$(INSTALL_DATA) ./files/getimsi.gcom $(1)/etc/gcom/getimsi.gcom
$(INSTALL_DIR) $(1)/etc/hotplug.d/tty
- $(INSTALL_DATA) ./files/3g.usb $(1)/etc/hotplug.d/tty/30-3g
+ $(INSTALL_CONF) ./files/3g.usb $(1)/etc/hotplug.d/tty/30-3g
$(INSTALL_DIR) $(1)/lib/netifd/proto
- $(INSTALL_BIN) ./files/3g.sh $(1)/lib/netifd/proto/3g.sh
+ $(INSTALL_CONF) ./files/3g.sh $(1)/lib/netifd/proto/3g.sh
endef
define Package/comgt-directip/install