aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorMarty Jones <mj8263788@gmail.com>2020-11-23 21:49:10 -0500
committerPetr Štetiar <ynezz@true.cz>2020-12-11 13:57:04 +0100
commitb63e57ba1795dfedd425d5cd6fffdae56274b3d1 (patch)
treedffcc64dd5c64b11974813481c76e69dbfd039b6 /package
parente401a2a42e6d7c892e1cf7d765fa5ec9b2db3fb3 (diff)
downloadupstream-b63e57ba1795dfedd425d5cd6fffdae56274b3d1.tar.gz
upstream-b63e57ba1795dfedd425d5cd6fffdae56274b3d1.tar.bz2
upstream-b63e57ba1795dfedd425d5cd6fffdae56274b3d1.zip
kernel: add Aquantia AQtion USB-to-5GbE adapters
This add support for USB-to-Ethernet Aquantia AQtion 5/2.5GbE adapters based on the AQC111U controllers. Run-tested: x86 Adapter-tested: Sabrent NT-SS5G Signed-off-by: Marty Jones <mj8263788@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/usb.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index eaf9eadb28..81a7f00066 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1104,6 +1104,21 @@ define AddDepends/usb-net
endef
+define KernelPackage/usb-net-aqc111
+ TITLE:=Support for USB-to-Ethernet Aquantia AQtion 5/2.5GbE
+ KCONFIG:=CONFIG_USB_NET_AQC111
+ FILES:=$(LINUX_DIR)/drivers/$(USBNET_DIR)/aqc111.ko
+ AUTOLOAD:=$(call AutoProbe,aqc111)
+ $(call AddDepends/usb-net)
+endef
+
+define KernelPackage/usb-net-aqc111/description
+ Support for USB-to-Ethernet Aquantia AQtion 5/2.5GbE
+endef
+
+$(eval $(call KernelPackage,usb-net-aqc111))
+
+
define KernelPackage/usb-net-asix
TITLE:=Kernel module for USB-to-Ethernet Asix convertors
DEPENDS:=+kmod-libphy