aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index eaf9eadb28..81a7f00066 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1104,6 +1104,21 @@ define AddDepends/usb-net
endef
+define KernelPackage/usb-net-aqc111
+ TITLE:=Support for USB-to-Ethernet Aquantia AQtion 5/2.5GbE
+ KCONFIG:=CONFIG_USB_NET_AQC111
+ FILES:=$(LINUX_DIR)/drivers/$(USBNET_DIR)/aqc111.ko
+ AUTOLOAD:=$(call AutoProbe,aqc111)
+ $(call AddDepends/usb-net)
+endef
+
+define KernelPackage/usb-net-aqc111/description
+ Support for USB-to-Ethernet Aquantia AQtion 5/2.5GbE
+endef
+
+$(eval $(call KernelPackage,usb-net-aqc111))
+
+
define KernelPackage/usb-net-asix
TITLE:=Kernel module for USB-to-Ethernet Asix convertors
DEPENDS:=+kmod-libphy