aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2020-02-23 16:41:16 +0100
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2020-02-28 17:50:46 +0100
commita847e0ddd2ef0f510b9e398c679cd35a105c5343 (patch)
treeae4a10b029cb20b0f0c3975a58ba545c5803d6ac /package
parent59f2814c095883d2058361f4c19bc8eaa384efa8 (diff)
downloadupstream-a847e0ddd2ef0f510b9e398c679cd35a105c5343.tar.gz
upstream-a847e0ddd2ef0f510b9e398c679cd35a105c5343.tar.bz2
upstream-a847e0ddd2ef0f510b9e398c679cd35a105c5343.zip
kernel: Add snd-intel-nhlt.ko to kmod-sound-hda-intel
With kernel 5.4 kmod-sound-hda-intel also needs snd-intel-nhlt.ko, but this kernel module is only build on x86, make the OpenWrt kmod depend on TARGET_x86. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/sound.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index a49ba6da6a..f975103e50 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -502,11 +502,13 @@ $(eval $(call KernelPackage,sound-hda-codec-hdmi))
define KernelPackage/sound-hda-intel
SUBMENU:=$(SOUND_MENU)
TITLE:=HD Audio Intel Driver
+ DEPENDS:=@TARGET_x86
KCONFIG:= \
CONFIG_SOUND_PCI \
CONFIG_SND_HDA_INTEL
FILES:= \
- $(LINUX_DIR)/sound/pci/hda/snd-hda-intel.ko
+ $(LINUX_DIR)/sound/pci/hda/snd-hda-intel.ko \
+ $(LINUX_DIR)/sound/hda/snd-intel-nhlt.ko@ge5.4
AUTOLOAD:=$(call AutoProbe,snd-hda-intel)
$(call AddDepends/sound,kmod-sound-hda-core)
endef