aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/sound.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/sound.mk')
-rw-r--r--package/kernel/linux/modules/sound.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index a49ba6da6a..f975103e50 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -502,11 +502,13 @@ $(eval $(call KernelPackage,sound-hda-codec-hdmi))
define KernelPackage/sound-hda-intel
SUBMENU:=$(SOUND_MENU)
TITLE:=HD Audio Intel Driver
+ DEPENDS:=@TARGET_x86
KCONFIG:= \
CONFIG_SOUND_PCI \
CONFIG_SND_HDA_INTEL
FILES:= \
- $(LINUX_DIR)/sound/pci/hda/snd-hda-intel.ko
+ $(LINUX_DIR)/sound/pci/hda/snd-hda-intel.ko \
+ $(LINUX_DIR)/sound/hda/snd-intel-nhlt.ko@ge5.4
AUTOLOAD:=$(call AutoProbe,snd-hda-intel)
$(call AddDepends/sound,kmod-sound-hda-core)
endef