aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-23 10:00:17 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-24 16:21:24 +0100
commit981ec49b90903809770011eeaa875ef43c23724a (patch)
treec9683ca3967a23566d01b92bd8fb8132741efcea /package
parent04cc026a7eae839dc9cf817836543bd39e74f584 (diff)
downloadupstream-981ec49b90903809770011eeaa875ef43c23724a.tar.gz
upstream-981ec49b90903809770011eeaa875ef43c23724a.tar.bz2
upstream-981ec49b90903809770011eeaa875ef43c23724a.zip
uboot-at91: switch to u-boot.mk
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package')
-rw-r--r--package/boot/uboot-at91/Makefile82
1 files changed, 11 insertions, 71 deletions
diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
index cbce85967e..6a806ff635 100644
--- a/package/boot/uboot-at91/Makefile
+++ b/package/boot/uboot-at91/Makefile
@@ -7,96 +7,36 @@
include $(TOPDIR)/rules.mk
-PKG_NAME:=u-boot
PKG_VERSION:=2016.05
PKG_RELEASE:=1
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:= \
- http://mirror2.openwrt.org/sources \
- ftp://ftp.denx.de/pub/u-boot
PKG_HASH:=87d02275615aaf0cd007b54cbe9fbadceef2bee7c79e6c323ea1ae8956dcb171
-PKG_LICENSE:=GPL-2.0 GPL-2.0+
-PKG_LICENSE_FILES:=Licenses/README
-
-PKG_BUILD_PARALLEL:=1
-
+include $(INCLUDE_DIR)/u-boot.mk
include $(INCLUDE_DIR)/package.mk
-define uboot/Default
- TITLE:=
+define U-Boot/Default
+ BUILD_TARGET:=at91
+ BUILD_SUBTARGET:=legacy
+ UBOOT_IMAGE:=u-boot.bin boot.bin
endef
-define uboot/at91sam9m10g45ek_nandflash
- TITLE:=U-Boot for the AT91SAM9M10G45-EK board (NandFlash)
+define U-Boot/at91sam9m10g45ek_nandflash
+ NAME:=AT91SAM9M10G45-EK board (NandFlash)
endef
-define uboot/at91sam9x5ek_nandflash
- TITLE:=U-Boot for the AT91SAM9X5-EK board (NandFlash)
+define U-Boot/at91sam9x5ek_nandflash
+ NAME:=AT91SAM9X5-EK board (NandFlash)
endef
-UBOOTS := \
+UBOOT_TARGETS := \
at91sam9m10g45ek_nandflash \
at91sam9x5ek_nandflash
-define Package/uboot/template
-define Package/uboot-at91-$(1)
- SECTION:=boot
- CATEGORY:=Boot Loaders
- DEPENDS:=@TARGET_at91
- TITLE:=$(2)
- URL:=http://www.denx.de/wiki/U-Boot
- VARIANT:=$(1)
- MAINTAINER:=Ben Whitten <ben.whitten@gmail.com>
-endef
-endef
-
-define BuildUBootPackage
- $(eval $(uboot/Default))
- $(eval $(uboot/$(1)))
- $(call Package/uboot/template,$(1),$(TITLE))
-endef
-
-ifdef BUILD_VARIANT
-$(eval $(call uboot/$(BUILD_VARIANT)))
-UBOOT_CONFIG:=$(if $(CONFIG),$(CONFIG),$(BUILD_VARIANT))
-UBOOT_IMAGE:=$(if $(IMAGE),$(IMAGE),lede-$(BOARD)-$(BUILD_VARIANT)-u-boot.bin)
-endif
-
-define Build/Configure
- +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
- $(UBOOT_CONFIG)_config
-endef
-
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
CROSS_COMPILE=$(TARGET_CROSS) \
KCFLAGS="$(filter-out -fstack-protector, $(TARGET_CFLAGS))"
endef
-define Package/uboot/install/default
- $(INSTALL_DIR) $(BIN_DIR)/uboot-$(BOARD)-$(1)
-
- $(CP) $(PKG_BUILD_DIR)/u-boot.bin \
- $(BIN_DIR)/uboot-$(BOARD)-$(1)/u-boot.bin
-
- $(CP) $(PKG_BUILD_DIR)/boot.bin \
- $(BIN_DIR)/uboot-$(BOARD)-$(1)/boot.bin
-endef
-
-define Package/uboot/install/template
-define Package/uboot-at91-$(1)/install
- $(call Package/uboot/install/default,$(2))
-endef
-endef
-
-$(foreach u,$(UBOOTS), \
- $(eval $(call Package/uboot/install/template,$(u),$(u))) \
-)
-
-$(foreach u,$(UBOOTS), \
- $(eval $(call BuildUBootPackage,$(u))) \
- $(eval $(call BuildPackage,uboot-at91-$(u))) \
-)
+$(eval $(call BuildPackage/U-Boot))