aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-23 09:25:26 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-24 16:21:24 +0100
commit04cc026a7eae839dc9cf817836543bd39e74f584 (patch)
tree5920895d7c9769e7a8519b32aaf0e3550b0eb07b /package
parent83783f296a18e6e481f23b2019575e45c437db4e (diff)
downloadupstream-04cc026a7eae839dc9cf817836543bd39e74f584.tar.gz
upstream-04cc026a7eae839dc9cf817836543bd39e74f584.tar.bz2
upstream-04cc026a7eae839dc9cf817836543bd39e74f584.zip
uboot-kirkwood: switch to u-boot.mk
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package')
-rw-r--r--package/boot/uboot-kirkwood/Makefile116
1 files changed, 38 insertions, 78 deletions
diff --git a/package/boot/uboot-kirkwood/Makefile b/package/boot/uboot-kirkwood/Makefile
index c42f947612..089188a295 100644
--- a/package/boot/uboot-kirkwood/Makefile
+++ b/package/boot/uboot-kirkwood/Makefile
@@ -7,74 +7,64 @@
include $(TOPDIR)/rules.mk
-PKG_NAME:=u-boot
PKG_VERSION:=2016.09.01
PKG_RELEASE:=1
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=\
- http://mirror2.openwrt.org/sources \
- ftp://ftp.denx.de/pub/u-boot
PKG_HASH:=95728e89dd476d17428f94080752ab48884be477b6a678941582aeef618b70bb
-PKG_TARGETS:=bin
-
-PKG_LICENSE:=GPL-2.0 GPL-2.0+
-PKG_LICENSE_FILES:=Licenses/README
-
-PKG_BUILD_PARALLEL:=1
+include $(INCLUDE_DIR)/u-boot.mk
include $(INCLUDE_DIR)/package.mk
-define uboot/Default
- TITLE:=
+define U-Boot/Default
+ BUILD_TARGET:=kirkwood
+ BUILD_DEVICES:=$(patsubst %_second_stage,%,$(1))
endef
-define uboot/dockstar
- TITLE:=U-Boot for Seagate DockStar
+define U-Boot/dockstar
+ NAME:=Seagate DockStar
endef
-define uboot/dockstar_second_stage
- TITLE:=second stage U-Boot for Seagate DockStar
+define U-Boot/dockstar_second_stage
+ NAME:=Seagate DockStar (second stage)
endef
-define uboot/goflexhome
- TITLE:=U-Boot for the Seagate GoFlexHome/GoFlexNet
+define U-Boot/goflexhome
+ NAME:=the Seagate GoFlexHome/GoFlexNet
endef
-define uboot/ib62x0
- TITLE:=U-Boot for RaidSonic ICY BOX NAS6210 and NAS6220
+define U-Boot/ib62x0
+ NAME:=RaidSonic ICY BOX NAS6210 and NAS6220
endef
-define uboot/ib62x0_second_stage
- TITLE:=second stage U-Boot for RaidSonic ICY BOX NAS6210 and NAS6220
+define U-Boot/ib62x0_second_stage
+ NAME:=RaidSonic ICY BOX NAS6210 and NAS6220 (second stage)
endef
-define uboot/iconnect
- TITLE:=U-Boot for Iomega iConnect Wireless
+define U-Boot/iconnect
+ NAME:=Iomega iConnect Wireless
endef
-define uboot/iconnect_second_stage
- TITLE:=second stage U-Boot for Iomega iConnect Wireless
+define U-Boot/iconnect_second_stage
+ NAME:=Iomega iConnect Wireless (second stage)
endef
-define uboot/nsa310
- TITLE:=U-Boot for Zyxel NSA310
+define U-Boot/nsa310
+ NAME:=Zyxel NSA310
endef
-define uboot/pogo_e02
- TITLE:=U-Boot for Cloud Engines Pogoplug E02
+define U-Boot/pogo_e02
+ NAME:=Cloud Engines Pogoplug E02
endef
-define uboot/pogo_e02_second_stage
- TITLE:=second stage U-Boot for Cloud Engines Pogoplug E02
+define U-Boot/pogo_e02_second_stage
+ NAME:=Cloud Engines Pogoplug E02 (second stage)
endef
-define uboot/sheevaplug
- TITLE:=U-Boot for SheevaPlug
+define U-Boot/sheevaplug
+ NAME:=SheevaPlug
endef
-UBOOTS:= \
+UBOOT_TARGETS := \
dockstar dockstar_second_stage \
goflexhome \
ib62x0 ib62x0_second_stage \
@@ -83,23 +73,6 @@ UBOOTS:= \
pogo_e02 pogo_e02_second_stage \
sheevaplug
-define Package/uboot/template
-define Package/uboot-kirkwood-$(1)
- SECTION:=boot
- CATEGORY:=Boot Loaders
- DEPENDS:=@TARGET_kirkwood
- TITLE:=$(2)
- URL:=http://www.denx.de/wiki/U-Boot
- VARIANT:=$(1)
-endef
-endef
-
-define BuildUBootPackage
- $(eval $(uboot/Default))
- $(eval $(uboot/$(1)))
- $(call Package/uboot/template,$(1),$(TITLE))
-endef
-
define Build/Configure
$(if $(findstring _second_stage,$(BUILD_VARIANT)),
$(CP) \
@@ -117,34 +90,21 @@ define Build/Compile
CROSS_COMPILE=$(TARGET_CROSS)
mkimage -A $(ARCH) -O linux -T kernel -C none \
-a 0x600000 -e 0x600000 \
- -n 'OpenWrt Das U-Boot uImage' \
+ -n 'U-Boot uImage' \
-d $(PKG_BUILD_DIR)/u-boot.bin $(PKG_BUILD_DIR)/u-boot.img
endef
-define Package/uboot/install/default
- $(INSTALL_DIR) $(BIN_DIR)/uboot-$(BOARD)-$(1)
- $(CP) $(PKG_BUILD_DIR)/u-boot.bin \
- $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-u-boot.bin
- $(CP) $(PKG_BUILD_DIR)/u-boot.kwb \
- $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-u-boot.kwb
- $(CP) $(PKG_BUILD_DIR)/u-boot.img \
- $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-u-boot.img
- $(INSTALL_DIR) $(BIN_DIR)/u-boot-kwboot/
- $(CP) $(PKG_BUILD_DIR)/tools/kwboot \
- $(BIN_DIR)/u-boot-kwboot/
+define Package/u-boot/install
+ $(CP) \
+ $(PKG_BUILD_DIR)/u-boot.bin \
+ $(PKG_BUILD_DIR)/u-boot.kwb \
+ $(PKG_BUILD_DIR)/u-boot.img \
+ $(1)/
endef
-define Package/uboot/install/template
-define Package/uboot-kirkwood-$(1)/install
- $(call Package/uboot/install/default,$(2))
+define Build/InstallDev
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/tools/kwboot $(STAGING_DIR_HOST)/bin/
endef
-endef
-
-$(foreach u,$(UBOOTS), \
- $(eval $(call Package/uboot/install/template,$(u),$(u))) \
-)
-$(foreach u,$(UBOOTS), \
- $(eval $(call BuildUBootPackage,$(u))) \
- $(eval $(call BuildPackage,uboot-kirkwood-$(u))) \
-)
+$(eval $(call BuildPackage/U-Boot))