aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-08-25 23:10:40 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-08-25 23:10:40 +0000
commit865e34b607a790798ab24adeb02bd064eb20f903 (patch)
tree33e2b43bdd2b1dfd41463bca36dbcc7a85197c22 /package
parent93c38f2b860ae7e35fc62b01c5960d85d5d2ccc7 (diff)
downloadupstream-865e34b607a790798ab24adeb02bd064eb20f903.tar.gz
upstream-865e34b607a790798ab24adeb02bd064eb20f903.tar.bz2
upstream-865e34b607a790798ab24adeb02bd064eb20f903.zip
ppp: populate gateway of default route with peer address (#6259)
SVN-Revision: 22806
Diffstat (limited to 'package')
-rw-r--r--package/ppp/Makefile2
-rw-r--r--package/ppp/patches/340-populate_default_gateway.patch21
2 files changed, 22 insertions, 1 deletions
diff --git a/package/ppp/Makefile b/package/ppp/Makefile
index 168895544e..8670dca132 100644
--- a/package/ppp/Makefile
+++ b/package/ppp/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ppp
PKG_VERSION:=2.4.4
-PKG_RELEASE:=9
+PKG_RELEASE:=10
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
diff --git a/package/ppp/patches/340-populate_default_gateway.patch b/package/ppp/patches/340-populate_default_gateway.patch
new file mode 100644
index 0000000000..ca11206c4d
--- /dev/null
+++ b/package/ppp/patches/340-populate_default_gateway.patch
@@ -0,0 +1,21 @@
+--- a/pppd/sys-linux.c
++++ b/pppd/sys-linux.c
+@@ -1673,6 +1673,9 @@ int sifdefaultroute (int unit, u_int32_t
+ memset (&rt, 0, sizeof (rt));
+ SET_SA_FAMILY (rt.rt_dst, AF_INET);
+
++ SET_SA_FAMILY(rt.rt_gateway, AF_INET);
++ SIN_ADDR(rt.rt_gateway) = gateway;
++
+ rt.rt_dev = ifname;
+
+ if (kernel_version > KVERSION(2,1,0)) {
+@@ -1680,7 +1683,7 @@ int sifdefaultroute (int unit, u_int32_t
+ SIN_ADDR(rt.rt_genmask) = 0L;
+ }
+
+- rt.rt_flags = RTF_UP;
++ rt.rt_flags = RTF_UP | RTF_GATEWAY;
+ if (ioctl(sock_fd, SIOCADDRT, &rt) < 0) {
+ if (!ok_error(errno))
+ error("default route ioctl(SIOCADDRT): %m");