aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-08-25 21:38:48 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-08-25 21:38:48 +0000
commit93c38f2b860ae7e35fc62b01c5960d85d5d2ccc7 (patch)
treeb80f7c7a741d8c671c622a2b9580c7f9fbf10c7e /package
parent48af005b737afd2ebb54e9984aa38b97146bb2c2 (diff)
downloadupstream-93c38f2b860ae7e35fc62b01c5960d85d5d2ccc7.tar.gz
upstream-93c38f2b860ae7e35fc62b01c5960d85d5d2ccc7.tar.bz2
upstream-93c38f2b860ae7e35fc62b01c5960d85d5d2ccc7.zip
uhttpd: fix segfault triggered by Basic Auth checking
SVN-Revision: 22805
Diffstat (limited to 'package')
-rw-r--r--package/uhttpd/Makefile2
-rw-r--r--package/uhttpd/src/uhttpd-utils.c2
2 files changed, 1 insertions, 3 deletions
diff --git a/package/uhttpd/Makefile b/package/uhttpd/Makefile
index 1227174536..086c294580 100644
--- a/package/uhttpd/Makefile
+++ b/package/uhttpd/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uhttpd
-PKG_RELEASE:=16
+PKG_RELEASE:=17
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
PKG_BUILD_DEPENDS := libcyassl liblua
diff --git a/package/uhttpd/src/uhttpd-utils.c b/package/uhttpd/src/uhttpd-utils.c
index 8a06c930af..3821eb54cb 100644
--- a/package/uhttpd/src/uhttpd-utils.c
+++ b/package/uhttpd/src/uhttpd-utils.c
@@ -728,8 +728,6 @@ int uh_auth_check(
req->realm = realm;
break;
}
-
- realm = NULL;
}
/* found a realm matching the username */