aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2015-06-04 05:44:44 +0000
committerSteven Barth <cyrus@openwrt.org>2015-06-04 05:44:44 +0000
commit17c90e94cf1df8c28613cdc85f9fc8939d993014 (patch)
treeedf3fbd4f175054d208711eb255803bf94e5e190 /package
parent281cb95a9d7e6adcc671f3e93bc4316a1386b114 (diff)
downloadupstream-17c90e94cf1df8c28613cdc85f9fc8939d993014.tar.gz
upstream-17c90e94cf1df8c28613cdc85f9fc8939d993014.tar.bz2
upstream-17c90e94cf1df8c28613cdc85f9fc8939d993014.zip
Add sch_fq and sch_pie to the kmod-sched package.
These are two new packet schedulers introduced in Linux 3.12 and 3.14 respectively. sch_fq is a perfect fairness queueing scheduler that also adds pacing on host TCP flows, and sch_pie is an AQM. Having them available in kmod-sched makes it easier for people to test these new queueing schemes. Signed-off-by: Toke Høiland-Jørgensen <toke@toke.dk> SVN-Revision: 45885
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/netsupport.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 4483581bf4..adfdace360 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -802,6 +802,8 @@ define KernelPackage/sched
CONFIG_NET_SCH_TBF \
CONFIG_NET_SCH_SFQ \
CONFIG_NET_SCH_TEQL \
+ CONFIG_NET_SCH_FQ \
+ CONFIG_NET_SCH_PIE \
CONFIG_NET_CLS_BASIC \
CONFIG_NET_ACT_POLICE \
CONFIG_NET_ACT_IPT \