aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-06-03 13:59:14 +0000
committerJohn Crispin <john@openwrt.org>2015-06-03 13:59:14 +0000
commit281cb95a9d7e6adcc671f3e93bc4316a1386b114 (patch)
tree20c7904026a6942a728c21fb7322d25d56186804 /package
parent5fe5aeaa723cf37d5b80e56b781a37b41d8bc73a (diff)
downloadupstream-281cb95a9d7e6adcc671f3e93bc4316a1386b114.tar.gz
upstream-281cb95a9d7e6adcc671f3e93bc4316a1386b114.tar.bz2
upstream-281cb95a9d7e6adcc671f3e93bc4316a1386b114.zip
lldpd: add option to disable custom TLVs
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com> SVN-Revision: 45884
Diffstat (limited to 'package')
-rw-r--r--package/network/services/lldpd/Config.in5
-rw-r--r--package/network/services/lldpd/Makefile1
2 files changed, 6 insertions, 0 deletions
diff --git a/package/network/services/lldpd/Config.in b/package/network/services/lldpd/Config.in
index 448506d047..93d84e29ea 100644
--- a/package/network/services/lldpd/Config.in
+++ b/package/network/services/lldpd/Config.in
@@ -41,6 +41,11 @@ config LLDPD_WITH_DOT3
prompt "Enable Dot3 extension (PHY stuff)"
default y
+config LLDPD_WITH_CUSTOM
+ bool
+ prompt "Enable Custom TLVs"
+ default y
+
config LLDPD_WITH_JSON
bool
prompt "Enable JSON output for the LLDP Command-Line Interface"
diff --git a/package/network/services/lldpd/Makefile b/package/network/services/lldpd/Makefile
index cccb9ba5d7..81e4a8ffb0 100644
--- a/package/network/services/lldpd/Makefile
+++ b/package/network/services/lldpd/Makefile
@@ -100,6 +100,7 @@ CONFIGURE_ARGS += \
$(if $(CONFIG_LLDPD_WITH_LLDPMED),,--disable-lldpmed) \
$(if $(CONFIG_LLDPD_WITH_DOT1),,--disable-dot1) \
$(if $(CONFIG_LLDPD_WITH_DOT3),,--disable-dot3) \
+ $(if $(CONFIG_LLDPD_WITH_CUSTOM),,--disable-custom) \
$(if $(CONFIG_LLDPD_WITH_SONMP),,--disable-sonmp) \
$(if $(CONFIG_LLDPD_WITH_JSON),--with-json=json-c,--with-json=no)