aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-02-08 21:58:55 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-02-14 14:10:51 +0100
commit7d7aa2fd924c27829ec25f825481554dd81bce97 (patch)
tree658b87b89331670266163e522ea5fb52535633cb /package/utils
parente7bfda2c243e66a75ff966ba04c28b1590b5d24c (diff)
downloadupstream-7d7aa2fd924c27829ec25f825481554dd81bce97.tar.gz
upstream-7d7aa2fd924c27829ec25f825481554dd81bce97.tar.bz2
upstream-7d7aa2fd924c27829ec25f825481554dd81bce97.zip
brcm2708: rename target to bcm27xx
This change makes the names of Broadcom targets consistent by using the common notation based on SoC/CPU ID (which is used internally anyway), bcmXXXX instead of brcmXXXX. This is even used for target TITLE in make menuconfig already, only the short target name used brcm so far. Despite, since subtargets range from bcm2708 to bcm2711, it seems appropriate to use bcm27xx instead of bcm2708 (again, as already done for BOARDNAME). This also renames the packages brcm2708-userland and brcm2708-gpu-fw. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Acked-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'package/utils')
-rw-r--r--package/utils/bcm27xx-userland/Makefile (renamed from package/utils/brcm2708-userland/Makefile)18
-rw-r--r--package/utils/bcm27xx-userland/patches/001-interface-vcms_host-cmake-fixes.patch (renamed from package/utils/brcm2708-userland/patches/001-interface-vcms_host-cmake-fixes.patch)0
2 files changed, 9 insertions, 9 deletions
diff --git a/package/utils/brcm2708-userland/Makefile b/package/utils/bcm27xx-userland/Makefile
index 7fea952974..718e853993 100644
--- a/package/utils/brcm2708-userland/Makefile
+++ b/package/utils/bcm27xx-userland/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
-PKG_NAME:=brcm2708-userland
+PKG_NAME:=bcm27xx-userland
PKG_VERSION:=42ec119e03eb8dffc7c83e2ac0e665e333abbef6
PKG_RELEASE:=1
@@ -34,19 +34,19 @@ include $(INCLUDE_DIR)/cmake.mk
TAR_OPTIONS:=--strip-components 1 $(TAR_OPTIONS)
TAR_CMD=$(HOST_TAR) -C $(1) $(TAR_OPTIONS)
-define Package/brcm2708-userland
+define Package/bcm27xx-userland
SECTION:=utils
CATEGORY:=Utilities
- DEPENDS:=@TARGET_brcm2708
- TITLE:=BCM2708 userland tools
- DEFAULT:=y if TARGET_brcm2708
+ DEPENDS:=@TARGET_bcm27xx
+ TITLE:=BCM27xx userland tools
+ DEFAULT:=y if TARGET_bcm27xx
endef
-define Package/brcm2708-userland/description
- BCM2708 userland tools including vcgencmd and tvservice.
+define Package/bcm27xx-userland/description
+ BCM27xx userland tools including vcgencmd and tvservice.
endef
-define Package/brcm2708-userland/install
+define Package/bcm27xx-userland/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dtparam $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dtoverlay $(1)/usr/bin
@@ -61,4 +61,4 @@ define Package/brcm2708-userland/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/ $(1)/usr/
endef
-$(eval $(call BuildPackage,brcm2708-userland))
+$(eval $(call BuildPackage,bcm27xx-userland))
diff --git a/package/utils/brcm2708-userland/patches/001-interface-vcms_host-cmake-fixes.patch b/package/utils/bcm27xx-userland/patches/001-interface-vcms_host-cmake-fixes.patch
index cb73512af9..cb73512af9 100644
--- a/package/utils/brcm2708-userland/patches/001-interface-vcms_host-cmake-fixes.patch
+++ b/package/utils/bcm27xx-userland/patches/001-interface-vcms_host-cmake-fixes.patch