aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/lua
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2014-11-06 19:35:34 +0000
committerNicolas Thill <nico@openwrt.org>2014-11-06 19:35:34 +0000
commitf4417f7ad8f2da7d99c48eead14b0a2e8ad0f387 (patch)
treea0e28ec68139151407b3a76169cba65a52840029 /package/utils/lua
parentbd92e9806b35a0d9f6d8351eb274d2cdfcc142b9 (diff)
downloadupstream-f4417f7ad8f2da7d99c48eead14b0a2e8ad0f387.tar.gz
upstream-f4417f7ad8f2da7d99c48eead14b0a2e8ad0f387.tar.bz2
upstream-f4417f7ad8f2da7d99c48eead14b0a2e8ad0f387.zip
package/*: replace occurences of 'ln -sf' to '$(LN)'
Signed-off-by: Nicolas Thill <nico@openwrt.org> SVN-Revision: 43205
Diffstat (limited to 'package/utils/lua')
-rw-r--r--package/utils/lua/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/utils/lua/Makefile b/package/utils/lua/Makefile
index e7e011a405..e40188ed9e 100644
--- a/package/utils/lua/Makefile
+++ b/package/utils/lua/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -149,7 +149,7 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/include/lnum_config.h $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblua.{a,so*} $(1)/usr/lib/
- ln -sf liblua.so.$(PKG_VERSION) $(1)/usr/lib/liblualib.so
+ $(LN) liblua.so.$(PKG_VERSION) $(1)/usr/lib/liblualib.so
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_BUILD_DIR)/etc/lua.pc $(1)/usr/lib/pkgconfig/
endef