aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2014-11-06 19:35:34 +0000
committerNicolas Thill <nico@openwrt.org>2014-11-06 19:35:34 +0000
commitf4417f7ad8f2da7d99c48eead14b0a2e8ad0f387 (patch)
treea0e28ec68139151407b3a76169cba65a52840029 /package
parentbd92e9806b35a0d9f6d8351eb274d2cdfcc142b9 (diff)
downloadupstream-f4417f7ad8f2da7d99c48eead14b0a2e8ad0f387.tar.gz
upstream-f4417f7ad8f2da7d99c48eead14b0a2e8ad0f387.tar.bz2
upstream-f4417f7ad8f2da7d99c48eead14b0a2e8ad0f387.zip
package/*: replace occurences of 'ln -sf' to '$(LN)'
Signed-off-by: Nicolas Thill <nico@openwrt.org> SVN-Revision: 43205
Diffstat (limited to 'package')
-rw-r--r--package/base-files/Makefile6
-rw-r--r--package/kernel/ar7-atm/Makefile6
-rw-r--r--package/kernel/broadcom-wl/Makefile4
-rw-r--r--package/libs/toolchain/Makefile6
-rw-r--r--package/network/services/dropbear/Makefile10
-rw-r--r--package/network/services/hostapd/Makefile4
-rw-r--r--package/network/services/ppp/Makefile2
-rw-r--r--package/network/services/samba36/Makefile8
-rw-r--r--package/network/utils/curl/Makefile2
-rw-r--r--package/network/utils/wireless-tools/Makefile8
-rw-r--r--package/utils/e2fsprogs/Makefile8
-rw-r--r--package/utils/lua/Makefile4
12 files changed, 34 insertions, 34 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 83b9929ead..aeba973879 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -133,11 +133,11 @@ define Package/base-files/install
mkdir -p $(1)/sys
mkdir -p $(1)/www
mkdir -p $(1)/root
- ln -sf /proc/mounts $(1)/etc/mtab
+ $(LN) /proc/mounts $(1)/etc/mtab
rm -f $(1)/var
- ln -sf /tmp $(1)/var
+ $(LN) /tmp $(1)/var
mkdir -p $(1)/etc
- ln -sf /tmp/resolv.conf /tmp/fstab /tmp/TZ $(1)/etc/
+ $(LN) /tmp/resolv.conf /tmp/fstab /tmp/TZ $(1)/etc/
chmod 0600 $(1)/etc/shadow
chmod 1777 $(1)/tmp
diff --git a/package/kernel/ar7-atm/Makefile b/package/kernel/ar7-atm/Makefile
index 59e9e79183..2574568acc 100644
--- a/package/kernel/ar7-atm/Makefile
+++ b/package/kernel/ar7-atm/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -87,13 +87,13 @@ endef
define KernelPackage/sangam-atm-annex-a/install
mkdir -p $(1)/lib/firmware
$(INSTALL_DATA) $(PKG_BUILD_DIR)/ar0700mp.bin $(1)/lib/firmware/
- ln -sf ar0700mp.bin $(1)/lib/firmware/ar0700xx.bin
+ $(LN) ar0700mp.bin $(1)/lib/firmware/ar0700xx.bin
endef
define KernelPackage/sangam-atm-annex-b/install
mkdir -p $(1)/lib/firmware
$(INSTALL_DATA) $(PKG_BUILD_DIR)/ar0700db.bin $(1)/lib/firmware/
- ln -sf ar0700db.bin $(1)/lib/firmware/ar0700xx.bin
+ $(LN) ar0700db.bin $(1)/lib/firmware/ar0700xx.bin
endef
$(eval $(call KernelPackage,sangam-atm-annex-a))
diff --git a/package/kernel/broadcom-wl/Makefile b/package/kernel/broadcom-wl/Makefile
index 29137e0dc0..003986ccbe 100644
--- a/package/kernel/broadcom-wl/Makefile
+++ b/package/kernel/broadcom-wl/Makefile
@@ -166,8 +166,8 @@ endef
define Package/nas/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/nas $(1)/usr/sbin/
- ln -sf nas $(1)/usr/sbin/nas4not
- ln -sf nas $(1)/usr/sbin/nas4wds
+ $(LN) nas $(1)/usr/sbin/nas4not
+ $(LN) nas $(1)/usr/sbin/nas4wds
endef
$(eval $(call KernelPackage,brcm-wl))
diff --git a/package/libs/toolchain/Makefile b/package/libs/toolchain/Makefile
index be20c06424..1cb83fa126 100644
--- a/package/libs/toolchain/Makefile
+++ b/package/libs/toolchain/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2007-2012 OpenWrt.org
+# Copyright (C) 2007-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -427,7 +427,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
define Package/eglibc/install
$(CP) ./eglibc-files/* $(1)/
rm -f $(1)/etc/localtime
- ln -sf /tmp/localtime $(1)/etc/localtime
+ $(LN) /tmp/localtime $(1)/etc/localtime
$(INSTALL_DIR) $(1)/lib
$(CP) \
$(TOOLCHAIN_DIR)/lib/ld*.so.* \
@@ -476,7 +476,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
$(CP) \
$(TOOLCHAIN_DIR)/lib/libc.so* \
$(1)/lib/
- ln -s ../../lib/$(LD_MUSL_NAME) $(1)/usr/bin/ldd
+ $(LN) ../../lib/$(LD_MUSL_NAME) $(1)/usr/bin/ldd
endef
define Package/libc/install
diff --git a/package/network/services/dropbear/Makefile b/package/network/services/dropbear/Makefile
index d805f00cd3..12a836be37 100644
--- a/package/network/services/dropbear/Makefile
+++ b/package/network/services/dropbear/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -107,10 +107,10 @@ define Package/dropbear/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/dropbearmulti $(1)/usr/sbin/dropbear
$(INSTALL_DIR) $(1)/usr/bin
- ln -sf ../sbin/dropbear $(1)/usr/bin/scp
- ln -sf ../sbin/dropbear $(1)/usr/bin/ssh
- ln -sf ../sbin/dropbear $(1)/usr/bin/dbclient
- ln -sf ../sbin/dropbear $(1)/usr/bin/dropbearkey
+ $(LN) ../sbin/dropbear $(1)/usr/bin/scp
+ $(LN) ../sbin/dropbear $(1)/usr/bin/ssh
+ $(LN) ../sbin/dropbear $(1)/usr/bin/dbclient
+ $(LN) ../sbin/dropbear $(1)/usr/bin/dropbearkey
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_DATA) ./files/dropbear.config $(1)/etc/config/dropbear
$(INSTALL_DIR) $(1)/etc/init.d
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index d698c050a3..d8b3498b11 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -372,8 +372,8 @@ define Package/wpad/install
$(call Install/hostapd,$(1))
$(call Install/supplicant,$(1))
$(INSTALL_BIN) $(PKG_BUILD_DIR)/wpad $(1)/usr/sbin/
- ln -sf wpad $(1)/usr/sbin/hostapd
- ln -sf wpad $(1)/usr/sbin/wpa_supplicant
+ $(LN) wpad $(1)/usr/sbin/hostapd
+ $(LN) wpad $(1)/usr/sbin/wpa_supplicant
endef
Package/wpad-mini/install = $(Package/wpad/install)
diff --git a/package/network/services/ppp/Makefile b/package/network/services/ppp/Makefile
index 33b71ffe82..efb0a76fbb 100644
--- a/package/network/services/ppp/Makefile
+++ b/package/network/services/ppp/Makefile
@@ -191,7 +191,7 @@ define Package/ppp/install
$(INSTALL_CONF) ./files/etc/ppp/chap-secrets $(1)/etc/ppp/
$(INSTALL_DATA) ./files/etc/ppp/filter $(1)/etc/ppp/
$(INSTALL_DATA) ./files/etc/ppp/options $(1)/etc/ppp/
- ln -sf /tmp/resolv.conf.ppp $(1)/etc/ppp/resolv.conf
+ $(LN) /tmp/resolv.conf.ppp $(1)/etc/ppp/resolv.conf
$(INSTALL_DIR) $(1)/lib/netifd/proto
$(INSTALL_BIN) ./files/ppp.sh $(1)/lib/netifd/proto/
$(INSTALL_BIN) ./files/lib/netifd/ppp-up $(1)/lib/netifd/
diff --git a/package/network/services/samba36/Makefile b/package/network/services/samba36/Makefile
index 4dff34b3c9..16838be4df 100644
--- a/package/network/services/samba36/Makefile
+++ b/package/network/services/samba36/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2007-2012 OpenWrt.org
+# Copyright (C) 2007-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -135,9 +135,9 @@ define Package/samba36-server/install
$(INSTALL_BIN) ./files/samba.init $(1)/etc/init.d/samba
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_BIN)/samba_multicall $(1)/usr/sbin
- ln -sf samba_multicall $(1)/usr/sbin/smbd
- ln -sf samba_multicall $(1)/usr/sbin/nmbd
- ln -sf samba_multicall $(1)/usr/sbin/smbpasswd
+ $(LN) samba_multicall $(1)/usr/sbin/smbd
+ $(LN) samba_multicall $(1)/usr/sbin/nmbd
+ $(LN) samba_multicall $(1)/usr/sbin/smbpasswd
endef
define Package/samba36-client/install
diff --git a/package/network/utils/curl/Makefile b/package/network/utils/curl/Makefile
index a77fcc89a7..f78fa9e9a2 100644
--- a/package/network/utils/curl/Makefile
+++ b/package/network/utils/curl/Makefile
@@ -145,7 +145,7 @@ define Build/InstallDev
$(CP) $(PKG_BUILD_DIR)/libcurl.pc $(1)/usr/lib/pkgconfig/
$(SED) 's,-L$$$${exec_prefix}/lib,,g' $(1)/usr/bin/curl-config
[ -n "$(TARGET_LDFLAGS)" ] && $(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/libcurl.pc || true
- ln -sf $(STAGING_DIR)/usr/bin/curl-config $(2)/bin/
+ $(LN) $(STAGING_DIR)/usr/bin/curl-config $(2)/bin/
endef
define Package/curl/install
diff --git a/package/network/utils/wireless-tools/Makefile b/package/network/utils/wireless-tools/Makefile
index 64b6f9fc7a..67986baaa1 100644
--- a/package/network/utils/wireless-tools/Makefile
+++ b/package/network/utils/wireless-tools/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -73,14 +73,14 @@ define Build/InstallDev
$(CP) $(PKG_BUILD_DIR)/{iwlib,wireless}.h $(1)/usr/include/
mkdir -p $(1)/usr/lib
$(CP) $(PKG_BUILD_DIR)/libiw.so* $(1)/usr/lib/
- ln -sf libiw.so.$(PKG_VERSION) $(1)/usr/lib/libiw.so
+ $(LN) libiw.so.$(PKG_VERSION) $(1)/usr/lib/libiw.so
endef
define Package/wireless-tools/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/iwconfig $(1)/usr/sbin/
- ln -sf iwconfig $(1)/usr/sbin/iwlist
- ln -sf iwconfig $(1)/usr/sbin/iwpriv
+ $(LN) iwconfig $(1)/usr/sbin/iwlist
+ $(LN) iwconfig $(1)/usr/sbin/iwpriv
endef
define Package/libiw/install
diff --git a/package/utils/e2fsprogs/Makefile b/package/utils/e2fsprogs/Makefile
index 5dc878658c..d4fd8d7474 100644
--- a/package/utils/e2fsprogs/Makefile
+++ b/package/utils/e2fsprogs/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
# Copyright 2010 Vertical Communications
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -106,9 +106,9 @@ define Package/e2fsprogs/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/e2fsck $(1)/usr/sbin/
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/mke2fs $(1)/usr/sbin/
- ln -sf mke2fs $(1)/usr/sbin/mkfs.ext2
- ln -sf mke2fs $(1)/usr/sbin/mkfs.ext3
- ln -sf mke2fs $(1)/usr/sbin/mkfs.ext4
+ $(LN) mke2fs $(1)/usr/sbin/mkfs.ext2
+ $(LN) mke2fs $(1)/usr/sbin/mkfs.ext3
+ $(LN) mke2fs $(1)/usr/sbin/mkfs.ext4
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libe2p.so.* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/etc/init.d
diff --git a/package/utils/lua/Makefile b/package/utils/lua/Makefile
index e7e011a405..e40188ed9e 100644
--- a/package/utils/lua/Makefile
+++ b/package/utils/lua/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -149,7 +149,7 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/include/lnum_config.h $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblua.{a,so*} $(1)/usr/lib/
- ln -sf liblua.so.$(PKG_VERSION) $(1)/usr/lib/liblualib.so
+ $(LN) liblua.so.$(PKG_VERSION) $(1)/usr/lib/liblualib.so
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_BUILD_DIR)/etc/lua.pc $(1)/usr/lib/pkgconfig/
endef