aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/fstools
diff options
context:
space:
mode:
authorPierre Lebleu <pme.lebleu@gmail.com>2018-05-24 14:20:33 +0200
committerJohn Crispin <john@phrozen.org>2018-05-24 16:05:07 +0200
commite6b8ce4c081b0bdfbbd20477ecef18b285481b07 (patch)
tree7305d8f25ec4c694cec1d827aca46b39e2e43852 /package/system/fstools
parent253095131d7b1a22d9a97cf81640bb3cacc941e4 (diff)
downloadupstream-e6b8ce4c081b0bdfbbd20477ecef18b285481b07.tar.gz
upstream-e6b8ce4c081b0bdfbbd20477ecef18b285481b07.tar.bz2
upstream-e6b8ce4c081b0bdfbbd20477ecef18b285481b07.zip
fstools: Add the new options available in the menuconfig
Mounting using the zlib compression and mounting with full access accounting are now available in the menuconfig. Signed-off-by: Pierre Lebleu <pme.lebleu@gmail.com>
Diffstat (limited to 'package/system/fstools')
-rw-r--r--package/system/fstools/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/system/fstools/Makefile b/package/system/fstools/Makefile
index 494f90d2e6..ad5197af4b 100644
--- a/package/system/fstools/Makefile
+++ b/package/system/fstools/Makefile
@@ -33,6 +33,8 @@ include $(INCLUDE_DIR)/cmake.mk
TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
CMAKE_OPTIONS += $(if $(CONFIG_FSTOOLS_UBIFS_EXTROOT),-DCMAKE_UBIFS_EXTROOT=y)
+CMAKE_OPTIONS += $(if $(CONFIG_FSTOOLS_OVL_MOUNT_FULL_ACCESS_TIME),-DCMAKE_OVL_MOUNT_FULL_ACCESS_TIME=y)
+CMAKE_OPTIONS += $(if $(CONFIG_FSTOOLS_OVL_MOUNT_COMPRESS_ZLIB),-DCMAKE_OVL_MOUNT_COMPRESS_ZLIB=y)
define Package/fstools
SECTION:=base
@@ -50,6 +52,20 @@ define Package/fstools/config
default y
help
This option makes it possible to use extroot functionality if the root filesystem resides on an UBIFS partition
+
+ config FSTOOLS_OVL_MOUNT_FULL_ACCESS_TIME
+ depends on PACKAGE_fstools
+ bool "Full access time accounting"
+ default n
+ help
+ This option enables the full access time accounting (warning: it will increase the flash writes).
+
+ config FSTOOLS_OVL_MOUNT_COMPRESS_ZLIB
+ depends on PACKAGE_fstools
+ bool "Compress using zlib"
+ default n
+ help
+ This option enables the compression using zlib on the storage device.
endef
define Package/snapshot-tool