aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/system/fstools/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/system/fstools/Makefile b/package/system/fstools/Makefile
index 494f90d2e6..ad5197af4b 100644
--- a/package/system/fstools/Makefile
+++ b/package/system/fstools/Makefile
@@ -33,6 +33,8 @@ include $(INCLUDE_DIR)/cmake.mk
TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
CMAKE_OPTIONS += $(if $(CONFIG_FSTOOLS_UBIFS_EXTROOT),-DCMAKE_UBIFS_EXTROOT=y)
+CMAKE_OPTIONS += $(if $(CONFIG_FSTOOLS_OVL_MOUNT_FULL_ACCESS_TIME),-DCMAKE_OVL_MOUNT_FULL_ACCESS_TIME=y)
+CMAKE_OPTIONS += $(if $(CONFIG_FSTOOLS_OVL_MOUNT_COMPRESS_ZLIB),-DCMAKE_OVL_MOUNT_COMPRESS_ZLIB=y)
define Package/fstools
SECTION:=base
@@ -50,6 +52,20 @@ define Package/fstools/config
default y
help
This option makes it possible to use extroot functionality if the root filesystem resides on an UBIFS partition
+
+ config FSTOOLS_OVL_MOUNT_FULL_ACCESS_TIME
+ depends on PACKAGE_fstools
+ bool "Full access time accounting"
+ default n
+ help
+ This option enables the full access time accounting (warning: it will increase the flash writes).
+
+ config FSTOOLS_OVL_MOUNT_COMPRESS_ZLIB
+ depends on PACKAGE_fstools
+ bool "Compress using zlib"
+ default n
+ help
+ This option enables the compression using zlib on the storage device.
endef
define Package/snapshot-tool