aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2021-02-16 00:03:28 +0100
committerFelix Fietkau <nbd@nbd.name>2021-02-16 11:29:38 +0100
commitd02088762a701642b5eace2e6e80b17c6719dd78 (patch)
tree96bef329c649c75b888676913a1d8a2d221eb39f /package/network/utils
parenta5c4c404764e9125d7a6c435c2f8d840c68ceed2 (diff)
downloadupstream-d02088762a701642b5eace2e6e80b17c6719dd78.tar.gz
upstream-d02088762a701642b5eace2e6e80b17c6719dd78.tar.bz2
upstream-d02088762a701642b5eace2e6e80b17c6719dd78.zip
build: reorder more BuildPackages lines to deal with ABI_VERSION
After the ABI version rework, packages need to be declared in the order of their dependencies, so that dependent packages will use the right ABI version Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/network/utils')
-rw-r--r--package/network/utils/bpftools/Makefile2
-rw-r--r--package/network/utils/ipset/Makefile2
-rw-r--r--package/network/utils/iptables/Makefile9
-rw-r--r--package/network/utils/wireless-tools/Makefile2
4 files changed, 8 insertions, 7 deletions
diff --git a/package/network/utils/bpftools/Makefile b/package/network/utils/bpftools/Makefile
index 06a7a7adfd..7a25b35755 100644
--- a/package/network/utils/bpftools/Makefile
+++ b/package/network/utils/bpftools/Makefile
@@ -162,6 +162,6 @@ define Package/libbpf/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib$(LIB_SUFFIX)/libbpf.so.* $(1)/usr/lib/
endef
+$(eval $(call BuildPackage,libbpf))
$(eval $(call BuildPackage,bpftool-full))
$(eval $(call BuildPackage,bpftool-minimal))
-$(eval $(call BuildPackage,libbpf))
diff --git a/package/network/utils/ipset/Makefile b/package/network/utils/ipset/Makefile
index 2d0c561198..bc4945e0f6 100644
--- a/package/network/utils/ipset/Makefile
+++ b/package/network/utils/ipset/Makefile
@@ -69,5 +69,5 @@ define Package/libipset/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libipset*.so.* $(1)/usr/lib/
endef
-$(eval $(call BuildPackage,ipset))
$(eval $(call BuildPackage,libipset))
+$(eval $(call BuildPackage,ipset))
diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index 9f033de72f..b1ac0be4e8 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -657,6 +657,10 @@ define BuildPlugin
$$(eval $$(call BuildPackage,$(1)))
endef
+$(eval $(call BuildPackage,libxtables))
+$(eval $(call BuildPackage,libxtables-nft))
+$(eval $(call BuildPackage,libip4tc))
+$(eval $(call BuildPackage,libip6tc))
$(eval $(call BuildPackage,iptables))
$(eval $(call BuildPackage,iptables-nft))
$(eval $(call BuildPlugin,iptables-mod-conntrack-extra,$(IPT_CONNTRACK_EXTRA-m)))
@@ -685,7 +689,4 @@ $(eval $(call BuildPackage,ip6tables))
$(eval $(call BuildPackage,ip6tables-nft))
$(eval $(call BuildPlugin,ip6tables-extra,$(IPT_IPV6_EXTRA-m)))
$(eval $(call BuildPlugin,ip6tables-mod-nat,$(IPT_NAT6-m)))
-$(eval $(call BuildPackage,libip4tc))
-$(eval $(call BuildPackage,libip6tc))
-$(eval $(call BuildPackage,libxtables))
-$(eval $(call BuildPackage,libxtables-nft))
+
diff --git a/package/network/utils/wireless-tools/Makefile b/package/network/utils/wireless-tools/Makefile
index 485b85ddc7..52e246a59c 100644
--- a/package/network/utils/wireless-tools/Makefile
+++ b/package/network/utils/wireless-tools/Makefile
@@ -89,5 +89,5 @@ define Package/libiw/install
$(CP) $(PKG_BUILD_DIR)/libiw.so.* $(1)/usr/lib/
endef
-$(eval $(call BuildPackage,wireless-tools))
$(eval $(call BuildPackage,libiw))
+$(eval $(call BuildPackage,wireless-tools))