aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/libs/elfutils/Makefile5
-rw-r--r--package/network/utils/bpftools/Makefile2
-rw-r--r--package/network/utils/ipset/Makefile2
-rw-r--r--package/network/utils/iptables/Makefile9
-rw-r--r--package/network/utils/wireless-tools/Makefile2
-rw-r--r--package/system/uci/Makefile2
-rw-r--r--package/utils/e2fsprogs/Makefile2
7 files changed, 13 insertions, 11 deletions
diff --git a/package/libs/elfutils/Makefile b/package/libs/elfutils/Makefile
index f2b25d2c36..aa6743e688 100644
--- a/package/libs/elfutils/Makefile
+++ b/package/libs/elfutils/Makefile
@@ -95,7 +95,8 @@ define Package/libelf/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libelf{-*.so,*.so.*} $(1)/usr/lib/
endef
-$(eval $(call BuildPackage,libasm))
-$(eval $(call BuildPackage,libdw))
+# these lines need to be ordered by dependency because of ABI versioning
$(eval $(call BuildPackage,libelf))
+$(eval $(call BuildPackage,libdw))
+$(eval $(call BuildPackage,libasm))
$(eval $(call HostBuild))
diff --git a/package/network/utils/bpftools/Makefile b/package/network/utils/bpftools/Makefile
index 06a7a7adfd..7a25b35755 100644
--- a/package/network/utils/bpftools/Makefile
+++ b/package/network/utils/bpftools/Makefile
@@ -162,6 +162,6 @@ define Package/libbpf/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib$(LIB_SUFFIX)/libbpf.so.* $(1)/usr/lib/
endef
+$(eval $(call BuildPackage,libbpf))
$(eval $(call BuildPackage,bpftool-full))
$(eval $(call BuildPackage,bpftool-minimal))
-$(eval $(call BuildPackage,libbpf))
diff --git a/package/network/utils/ipset/Makefile b/package/network/utils/ipset/Makefile
index 2d0c561198..bc4945e0f6 100644
--- a/package/network/utils/ipset/Makefile
+++ b/package/network/utils/ipset/Makefile
@@ -69,5 +69,5 @@ define Package/libipset/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libipset*.so.* $(1)/usr/lib/
endef
-$(eval $(call BuildPackage,ipset))
$(eval $(call BuildPackage,libipset))
+$(eval $(call BuildPackage,ipset))
diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index 9f033de72f..b1ac0be4e8 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -657,6 +657,10 @@ define BuildPlugin
$$(eval $$(call BuildPackage,$(1)))
endef
+$(eval $(call BuildPackage,libxtables))
+$(eval $(call BuildPackage,libxtables-nft))
+$(eval $(call BuildPackage,libip4tc))
+$(eval $(call BuildPackage,libip6tc))
$(eval $(call BuildPackage,iptables))
$(eval $(call BuildPackage,iptables-nft))
$(eval $(call BuildPlugin,iptables-mod-conntrack-extra,$(IPT_CONNTRACK_EXTRA-m)))
@@ -685,7 +689,4 @@ $(eval $(call BuildPackage,ip6tables))
$(eval $(call BuildPackage,ip6tables-nft))
$(eval $(call BuildPlugin,ip6tables-extra,$(IPT_IPV6_EXTRA-m)))
$(eval $(call BuildPlugin,ip6tables-mod-nat,$(IPT_NAT6-m)))
-$(eval $(call BuildPackage,libip4tc))
-$(eval $(call BuildPackage,libip6tc))
-$(eval $(call BuildPackage,libxtables))
-$(eval $(call BuildPackage,libxtables-nft))
+
diff --git a/package/network/utils/wireless-tools/Makefile b/package/network/utils/wireless-tools/Makefile
index 485b85ddc7..52e246a59c 100644
--- a/package/network/utils/wireless-tools/Makefile
+++ b/package/network/utils/wireless-tools/Makefile
@@ -89,5 +89,5 @@ define Package/libiw/install
$(CP) $(PKG_BUILD_DIR)/libiw.so.* $(1)/usr/lib/
endef
-$(eval $(call BuildPackage,wireless-tools))
$(eval $(call BuildPackage,libiw))
+$(eval $(call BuildPackage,wireless-tools))
diff --git a/package/system/uci/Makefile b/package/system/uci/Makefile
index fca800a541..4fd5568bfb 100644
--- a/package/system/uci/Makefile
+++ b/package/system/uci/Makefile
@@ -84,6 +84,6 @@ define Build/InstallDev
$(CP) $(PKG_BUILD_DIR)/libucimap.a $(1)/usr/lib
endef
-$(eval $(call BuildPackage,uci))
$(eval $(call BuildPackage,libuci))
$(eval $(call BuildPackage,libuci-lua))
+$(eval $(call BuildPackage,uci))
diff --git a/package/utils/e2fsprogs/Makefile b/package/utils/e2fsprogs/Makefile
index 43ad42602a..3d64fab587 100644
--- a/package/utils/e2fsprogs/Makefile
+++ b/package/utils/e2fsprogs/Makefile
@@ -315,10 +315,10 @@ define Package/lsattr/install
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/lsattr $(1)/usr/bin/
endef
-$(eval $(call BuildPackage,e2fsprogs))
$(eval $(call BuildPackage,libcomerr))
$(eval $(call BuildPackage,libss))
$(eval $(call BuildPackage,libext2fs))
+$(eval $(call BuildPackage,e2fsprogs))
$(eval $(call BuildPackage,tune2fs))
$(eval $(call BuildPackage,resize2fs))
$(eval $(call BuildPackage,badblocks))