aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/ipset/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2019-01-22 19:17:32 +0100
committerJo-Philipp Wich <jo@mein.io>2019-01-24 10:39:30 +0100
commit0e70f69a35fd79be781c859c12487b626e243e96 (patch)
tree2025021f55f831e09f0f102969e01532881b8147 /package/network/utils/ipset/Makefile
parent60558790a2a832265ec041131e851b6648f514d4 (diff)
downloadupstream-0e70f69a35fd79be781c859c12487b626e243e96.tar.gz
upstream-0e70f69a35fd79be781c859c12487b626e243e96.tar.bz2
upstream-0e70f69a35fd79be781c859c12487b626e243e96.zip
treewide: revise library packaging
- Annotate versionless libraries (such as libubox, libuci etc.) with a fixed ABI_VERSION resembling the source date of the last incompatible change - Annotate packages shipping versioned library objects with ABI_VERSION - Stop shipping unversioned library symlinks for packages with ABI_VERSION Ref: https://openwrt.org/docs/guide-developer/package-policies#shared_libraries Ref: https://github.com/KanjiMonster/maintainer-tools/blob/master/check-abi-versions.pl Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/network/utils/ipset/Makefile')
-rw-r--r--package/network/utils/ipset/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/network/utils/ipset/Makefile b/package/network/utils/ipset/Makefile
index 7efbc40153..37cff3aca4 100644
--- a/package/network/utils/ipset/Makefile
+++ b/package/network/utils/ipset/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ipset
PKG_VERSION:=7.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://ipset.netfilter.org
@@ -39,6 +39,7 @@ endef
define Package/libipset
$(call Package/ipset/Default)
+ ABI_VERSION:=13
endef
CONFIGURE_ARGS += \
@@ -62,7 +63,7 @@ endef
define Package/libipset/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libipset*.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libipset*.so.* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,ipset))