aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2019-01-22 19:17:32 +0100
committerJo-Philipp Wich <jo@mein.io>2019-01-24 10:39:30 +0100
commit0e70f69a35fd79be781c859c12487b626e243e96 (patch)
tree2025021f55f831e09f0f102969e01532881b8147 /package/network
parent60558790a2a832265ec041131e851b6648f514d4 (diff)
downloadupstream-0e70f69a35fd79be781c859c12487b626e243e96.tar.gz
upstream-0e70f69a35fd79be781c859c12487b626e243e96.tar.bz2
upstream-0e70f69a35fd79be781c859c12487b626e243e96.zip
treewide: revise library packaging
- Annotate versionless libraries (such as libubox, libuci etc.) with a fixed ABI_VERSION resembling the source date of the last incompatible change - Annotate packages shipping versioned library objects with ABI_VERSION - Stop shipping unversioned library symlinks for packages with ABI_VERSION Ref: https://openwrt.org/docs/guide-developer/package-policies#shared_libraries Ref: https://github.com/KanjiMonster/maintainer-tools/blob/master/check-abi-versions.pl Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/utils/curl/Makefile3
-rw-r--r--package/network/utils/dante/Makefile5
-rw-r--r--package/network/utils/ipset/Makefile5
-rw-r--r--package/network/utils/iptables/Makefile10
-rw-r--r--package/network/utils/wireless-tools/Makefile3
5 files changed, 15 insertions, 11 deletions
diff --git a/package/network/utils/curl/Makefile b/package/network/utils/curl/Makefile
index 65ece77649..4d6674b818 100644
--- a/package/network/utils/curl/Makefile
+++ b/package/network/utils/curl/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=curl
PKG_VERSION:=7.63.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://dl.uxnr.de/mirror/curl/ \
@@ -91,6 +91,7 @@ define Package/libcurl
DEPENDS += +LIBCURL_SSH2:libssh2 +LIBCURL_NGHTTP2:libnghttp2 +ca-bundle
TITLE:=A client-side URL transfer library
MENU:=1
+ ABI_VERSION:=4
endef
define Package/libcurl/config
diff --git a/package/network/utils/dante/Makefile b/package/network/utils/dante/Makefile
index 1c57b120f8..4f5d08724c 100644
--- a/package/network/utils/dante/Makefile
+++ b/package/network/utils/dante/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dante
PKG_VERSION:=1.4.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.inet.no/dante/files/
@@ -58,6 +58,7 @@ define Package/libsocks
SECTION:=libs
CATEGORY:=Libraries
TITLE+= Library
+ ABI_VERSION:=0
endef
define Package/libsocks/description
@@ -67,7 +68,7 @@ endef
define Package/libsocks/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsocks.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsocks.so.* $(1)/usr/lib/
endef
diff --git a/package/network/utils/ipset/Makefile b/package/network/utils/ipset/Makefile
index 7efbc40153..37cff3aca4 100644
--- a/package/network/utils/ipset/Makefile
+++ b/package/network/utils/ipset/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ipset
PKG_VERSION:=7.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://ipset.netfilter.org
@@ -39,6 +39,7 @@ endef
define Package/libipset
$(call Package/ipset/Default)
+ ABI_VERSION:=13
endef
CONFIGURE_ARGS += \
@@ -62,7 +63,7 @@ endef
define Package/libipset/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libipset*.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libipset*.so.* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,ipset))
diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index c6e0a64966..d60e25cdc7 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=iptables
PKG_VERSION:=1.8.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://git.netfilter.org/iptables
@@ -632,24 +632,24 @@ endef
define Package/libiptc/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libiptc.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libiptc.so.* $(1)/usr/lib/
endef
define Package/libip4tc/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libip4tc.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libip4tc.so.* $(1)/usr/lib/
$(CP) $(PKG_BUILD_DIR)/extensions/libiptext4.so $(1)/usr/lib/
endef
define Package/libip6tc/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libip6tc.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libip6tc.so.* $(1)/usr/lib/
$(CP) $(PKG_BUILD_DIR)/extensions/libiptext6.so $(1)/usr/lib/
endef
define Package/libxtables/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libxtables.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libxtables.so.* $(1)/usr/lib/
$(CP) $(PKG_BUILD_DIR)/extensions/libiptext.so $(1)/usr/lib/
endef
diff --git a/package/network/utils/wireless-tools/Makefile b/package/network/utils/wireless-tools/Makefile
index dd3430a426..485b85ddc7 100644
--- a/package/network/utils/wireless-tools/Makefile
+++ b/package/network/utils/wireless-tools/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=wireless-tools
PKG_VERSION:=29
PKG_MINOR:=
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_SOURCE:=wireless_tools.$(PKG_VERSION)$(PKG_MINOR).tar.gz
PKG_SOURCE_URL:=https://hewlettpackard.github.io/wireless-tools
@@ -45,6 +45,7 @@ $(call Package/wireless-tools/Default)
SECTION:=libs
CATEGORY:=Libraries
TITLE:=Library for manipulating Linux Wireless Extensions
+ ABI_VERSION:=29
endef
define Package/libiw/description