aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config/gre
diff options
context:
space:
mode:
authorLorenzo Santina <lorenzo.santina@edu.unito.it>2017-09-11 15:27:53 +0200
committerMathias Kresin <dev@kresin.me>2017-09-13 08:07:54 +0200
commitfd84ecda7d3bfebb4237110b8efe2ab2713ea8e1 (patch)
tree5d2ed86484e32e8cdc6100e5615be7007cb5cee0 /package/network/config/gre
parentfb128057da92bdb6b2c4cd9ad9dd87637a4089b3 (diff)
downloadupstream-fd84ecda7d3bfebb4237110b8efe2ab2713ea8e1.tar.gz
upstream-fd84ecda7d3bfebb4237110b8efe2ab2713ea8e1.tar.bz2
upstream-fd84ecda7d3bfebb4237110b8efe2ab2713ea8e1.zip
treewide: fix shellscript syntax errors/typos
Fix multiple syntax errors in shelscripts (of packages only) These errors were causing many conditions to not working properly Signed-off-by: Lorenzo Santina <lorenzo.santina@edu.unito.it> [increase PKG_RELEASE, drop command substitution from directip.sh] Signed-off-by: Mathias Kresin <dev@kresin.em>
Diffstat (limited to 'package/network/config/gre')
-rw-r--r--package/network/config/gre/Makefile2
-rwxr-xr-xpackage/network/config/gre/files/gre.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/network/config/gre/Makefile b/package/network/config/gre/Makefile
index 9193f5c9fb..b191327f87 100644
--- a/package/network/config/gre/Makefile
+++ b/package/network/config/gre/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gre
PKG_VERSION:=1
-PKG_RELEASE:=7
+PKG_RELEASE:=8
PKG_LICENSE:=GPL-2.0
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/config/gre/files/gre.sh b/package/network/config/gre/files/gre.sh
index a6b4ba85f6..e604bfb259 100755
--- a/package/network/config/gre/files/gre.sh
+++ b/package/network/config/gre/files/gre.sh
@@ -25,7 +25,7 @@ gre_generic_setup() {
json_add_string mode "$mode"
json_add_int mtu "${mtu:-1280}"
[ -n "$df" ] && json_add_boolean df "$df"
- [ -n "ttl" ] && json_add_int ttl "$ttl"
+ [ -n "$ttl" ] && json_add_int ttl "$ttl"
[ -n "$tos" ] && json_add_string tos "$tos"
json_add_boolean multicast "$multicast"
json_add_string local "$local"