aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-09-27 17:21:23 +0100
committerDaniel Golle <daniel@makrotopia.org>2020-09-27 17:22:01 +0100
commitd96d32428067882b34cfebd2b59b7eaba9a96af3 (patch)
treed09575fca22f706aea0cf4e77fff994ab2e8084a /package/libs
parente8b34880f9776264837d0ba1604ef602ac93882e (diff)
downloadupstream-d96d32428067882b34cfebd2b59b7eaba9a96af3.tar.gz
upstream-d96d32428067882b34cfebd2b59b7eaba9a96af3.tar.bz2
upstream-d96d32428067882b34cfebd2b59b7eaba9a96af3.zip
libsepol: break out chkcon utility
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/libsepol/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/libs/libsepol/Makefile b/package/libs/libsepol/Makefile
index 2a6bd46ad0..8ceb7164a7 100644
--- a/package/libs/libsepol/Makefile
+++ b/package/libs/libsepol/Makefile
@@ -30,6 +30,18 @@ define Package/libsepol/description
depend upon or use any of the other SELinux components.
endef
+define Package/chkcon
+ SECTION:=utils
+ CATEGORY:=Utilities
+ DEPENDS:=+libsepol
+ TITLE:=libsepol chkcon security context validation tool
+ URL:=http://selinuxproject.org/page/Main_Page
+endef
+
+define Package/chkcon/description
+ chkcon - determine if a security context is valid for a given binary policy
+endef
+
HOST_MAKE_FLAGS += \
PREFIX=$(STAGING_DIR_HOSTPKG) \
SHLIBDIR=$(STAGING_DIR_HOSTPKG)/lib
@@ -62,5 +74,11 @@ define Package/libsepol/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libsepol.so.* $(1)/usr/lib/
endef
+define Package/chkcon/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/chkcon $(1)/usr/bin/
+endef
+
$(eval $(call HostBuild))
$(eval $(call BuildPackage,libsepol))
+$(eval $(call BuildPackage,chkcon))