aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libsepol/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs/libsepol/Makefile')
-rw-r--r--package/libs/libsepol/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/libs/libsepol/Makefile b/package/libs/libsepol/Makefile
index 2a6bd46ad0..8ceb7164a7 100644
--- a/package/libs/libsepol/Makefile
+++ b/package/libs/libsepol/Makefile
@@ -30,6 +30,18 @@ define Package/libsepol/description
depend upon or use any of the other SELinux components.
endef
+define Package/chkcon
+ SECTION:=utils
+ CATEGORY:=Utilities
+ DEPENDS:=+libsepol
+ TITLE:=libsepol chkcon security context validation tool
+ URL:=http://selinuxproject.org/page/Main_Page
+endef
+
+define Package/chkcon/description
+ chkcon - determine if a security context is valid for a given binary policy
+endef
+
HOST_MAKE_FLAGS += \
PREFIX=$(STAGING_DIR_HOSTPKG) \
SHLIBDIR=$(STAGING_DIR_HOSTPKG)/lib
@@ -62,5 +74,11 @@ define Package/libsepol/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libsepol.so.* $(1)/usr/lib/
endef
+define Package/chkcon/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/chkcon $(1)/usr/bin/
+endef
+
$(eval $(call HostBuild))
$(eval $(call BuildPackage,libsepol))
+$(eval $(call BuildPackage,chkcon))