aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-06-06 14:24:43 -0700
committerFelix Fietkau <nbd@nbd.name>2021-06-12 10:46:39 +0200
commit09de28090cfb3fb605e6f4b452503a4ec2c6c43f (patch)
tree0b6fbc87a8a72c03e9b5e524e0cbe44278965471 /package/libs
parent97258f53634d7237a2962aec3387f011047ce83b (diff)
downloadupstream-09de28090cfb3fb605e6f4b452503a4ec2c6c43f.tar.gz
upstream-09de28090cfb3fb605e6f4b452503a4ec2c6c43f.tar.bz2
upstream-09de28090cfb3fb605e6f4b452503a4ec2c6c43f.zip
package: fix cmake packages build with ninja
+= is needed for CMAKE_OPTIONS. mt76 needs Ninja disabled as the kernel stuff uses normal make. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/libubox/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/libs/libubox/Makefile b/package/libs/libubox/Makefile
index ac4effb6f8..aec4c9cc02 100644
--- a/package/libs/libubox/Makefile
+++ b/package/libs/libubox/Makefile
@@ -67,7 +67,7 @@ define Package/libubox-lua
endef
TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
-CMAKE_OPTIONS = \
+CMAKE_OPTIONS += \
-DLUAPATH=/usr/lib/lua \
-DABIVERSION="$(PKG_ABI_VERSION)"