aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-02-07 20:23:06 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2023-02-18 19:55:37 +0100
commit0859c7129f40fa40c0170a1d436b06aa543d8d26 (patch)
tree1f533063826ecdc2a3d856a484eed2098d5644f8 /package/libs
parent29d02d8ce584fa7e420204e04dde1e17e14e009c (diff)
downloadupstream-0859c7129f40fa40c0170a1d436b06aa543d8d26.tar.gz
upstream-0859c7129f40fa40c0170a1d436b06aa543d8d26.tar.bz2
upstream-0859c7129f40fa40c0170a1d436b06aa543d8d26.zip
elfutils: fix build with GCC 11
GCC 11 doesn't know about -Wno-error=use-after-free and aborts compilation. Fixes: 2748c45d "elfutils: Ignore wrong use-after-free error" Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/elfutils/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/package/libs/elfutils/Makefile b/package/libs/elfutils/Makefile
index 1e41e296b3..717403c124 100644
--- a/package/libs/elfutils/Makefile
+++ b/package/libs/elfutils/Makefile
@@ -81,7 +81,15 @@ HOST_CONFIGURE_VARS += \
CONFIGURE_VARS += \
ac_cv_search__obstack_free=yes
-TARGET_CFLAGS += -D_GNU_SOURCE -Wno-unused-result -Wno-format-nonliteral -Wno-error=use-after-free
+TARGET_CFLAGS += \
+ -D_GNU_SOURCE \
+ -Wno-unused-result \
+ -Wno-format-nonliteral
+
+ifneq ($(CONFIG_GCC_USE_VERSION_11),y)
+TARGET_CFLAGS += \
+ -Wno-error=use-after-free
+endif
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include