aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/elfutils/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs/elfutils/Makefile')
-rw-r--r--package/libs/elfutils/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/package/libs/elfutils/Makefile b/package/libs/elfutils/Makefile
index 1e41e296b3..717403c124 100644
--- a/package/libs/elfutils/Makefile
+++ b/package/libs/elfutils/Makefile
@@ -81,7 +81,15 @@ HOST_CONFIGURE_VARS += \
CONFIGURE_VARS += \
ac_cv_search__obstack_free=yes
-TARGET_CFLAGS += -D_GNU_SOURCE -Wno-unused-result -Wno-format-nonliteral -Wno-error=use-after-free
+TARGET_CFLAGS += \
+ -D_GNU_SOURCE \
+ -Wno-unused-result \
+ -Wno-format-nonliteral
+
+ifneq ($(CONFIG_GCC_USE_VERSION_11),y)
+TARGET_CFLAGS += \
+ -Wno-error=use-after-free
+endif
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include