aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/pcre
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-08-14 02:38:21 +0100
committerDaniel Golle <daniel@makrotopia.org>2020-08-14 02:42:25 +0100
commit4469e45f60842c8bc601b4c5b68b10d6aa74334d (patch)
tree91c0533c53fa09a028b75c9889fced399de43cb4 /package/libs/pcre
parentff02e1561f2073b39814f2d73205a5209471b115 (diff)
downloadupstream-4469e45f60842c8bc601b4c5b68b10d6aa74334d.tar.gz
upstream-4469e45f60842c8bc601b4c5b68b10d6aa74334d.tar.bz2
upstream-4469e45f60842c8bc601b4c5b68b10d6aa74334d.zip
pcre: clean up Makefile line order
The most recent patch added add lines in one block instead of in the appropriate places to keep Makefiles in consistent style. Fix that. Fixes: ff02e1561f ("pcre: add host variant of libpcre") Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/libs/pcre')
-rw-r--r--package/libs/pcre/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/package/libs/pcre/Makefile b/package/libs/pcre/Makefile
index 3655614169..bf3f733a5c 100644
--- a/package/libs/pcre/Makefile
+++ b/package/libs/pcre/Makefile
@@ -29,6 +29,7 @@ PKG_CONFIG_DEPENDS:=\
include $(INCLUDE_DIR)/uclibc++.mk
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
define Package/libpcre/default
SECTION:=libs
@@ -61,7 +62,6 @@ define Package/libpcrecpp
DEPENDS:=+libpcre $(CXX_DEPENDS)
endef
-include $(INCLUDE_DIR)/host-build.mk
HOST_CONFIGURE_ARGS += \
--enable-utf8 \
@@ -70,9 +70,6 @@ HOST_CONFIGURE_ARGS += \
--with-match-limit-recursion=16000 \
--enable-cpp
-$(eval $(call HostBuild))
-
-
TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS += \
@@ -129,3 +126,4 @@ $(eval $(call BuildPackage,libpcre))
$(eval $(call BuildPackage,libpcre16))
$(eval $(call BuildPackage,libpcre32))
$(eval $(call BuildPackage,libpcrecpp))
+$(eval $(call HostBuild))