aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/pcre
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>2020-07-14 16:32:28 -0500
committerDaniel Golle <daniel@makrotopia.org>2020-08-14 02:29:03 +0100
commitff02e1561f2073b39814f2d73205a5209471b115 (patch)
tree36b4c290a2ff8cadbc79e5c5ff3c675df7d13495 /package/libs/pcre
parent7ef7dbaf7057da37afeefa3753bc4d0f0453e51f (diff)
downloadupstream-ff02e1561f2073b39814f2d73205a5209471b115.tar.gz
upstream-ff02e1561f2073b39814f2d73205a5209471b115.tar.bz2
upstream-ff02e1561f2073b39814f2d73205a5209471b115.zip
pcre: add host variant of libpcre
This is needed to build the host variant of libselinux. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'package/libs/pcre')
-rw-r--r--package/libs/pcre/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/libs/pcre/Makefile b/package/libs/pcre/Makefile
index b638c876da..3655614169 100644
--- a/package/libs/pcre/Makefile
+++ b/package/libs/pcre/Makefile
@@ -61,6 +61,18 @@ define Package/libpcrecpp
DEPENDS:=+libpcre $(CXX_DEPENDS)
endef
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_CONFIGURE_ARGS += \
+ --enable-utf8 \
+ --enable-unicode-properties \
+ --enable-pcre16 \
+ --with-match-limit-recursion=16000 \
+ --enable-cpp
+
+$(eval $(call HostBuild))
+
+
TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS += \