aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorChen Minqiang <ptpt52@gmail.com>2021-04-21 13:27:42 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2021-04-30 23:51:23 +0200
commite219b7f38bd6516e23d5ee96ece2e0b351794deb (patch)
treeee13c11b6d2bc36b7702e8f69704e0f6152757c7 /package/kernel
parentaddf47a9a8228ed3099ebb010674e817b30284e0 (diff)
downloadupstream-e219b7f38bd6516e23d5ee96ece2e0b351794deb.tar.gz
upstream-e219b7f38bd6516e23d5ee96ece2e0b351794deb.tar.bz2
upstream-e219b7f38bd6516e23d5ee96ece2e0b351794deb.zip
kernel: add kmod-ipvlan support
This kmod is similar to macvlan with the difference being that the endpoints have the same mac address. It is useful on cloud where only one mac address allowed on port, where macvlan not works but ipvlan would. One use case is where multiple IPs and gateways assign on one net port Signed-off-by: Chen Minqiang <ptpt52@gmail.com>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/netdevices.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index bc6ed2c7aa..5c1f3b2ee7 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -885,6 +885,22 @@ endef
$(eval $(call KernelPackage,macvlan))
+define KernelPackage/ipvlan
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=IP-VLAN support
+ KCONFIG:=CONFIG_IPVLAN
+ FILES:=$(LINUX_DIR)/drivers/net/ipvlan/ipvlan.ko
+ AUTOLOAD:=$(call AutoProbe,ipvlan)
+endef
+
+define KernelPackage/ipvlan/description
+ A kernel module which allows one to create virtual interfaces that
+ map packets to or from specific IP addresses to a particular interface
+endef
+
+$(eval $(call KernelPackage,ipvlan))
+
+
define KernelPackage/tulip
TITLE:=Tulip family network device support
DEPENDS:=@PCI_SUPPORT +kmod-mii