aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/netdevices.mk16
-rw-r--r--target/linux/generic/config-5.101
-rw-r--r--target/linux/generic/config-5.41
3 files changed, 18 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index bc6ed2c7aa..5c1f3b2ee7 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -885,6 +885,22 @@ endef
$(eval $(call KernelPackage,macvlan))
+define KernelPackage/ipvlan
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=IP-VLAN support
+ KCONFIG:=CONFIG_IPVLAN
+ FILES:=$(LINUX_DIR)/drivers/net/ipvlan/ipvlan.ko
+ AUTOLOAD:=$(call AutoProbe,ipvlan)
+endef
+
+define KernelPackage/ipvlan/description
+ A kernel module which allows one to create virtual interfaces that
+ map packets to or from specific IP addresses to a particular interface
+endef
+
+$(eval $(call KernelPackage,ipvlan))
+
+
define KernelPackage/tulip
TITLE:=Tulip family network device support
DEPENDS:=@PCI_SUPPORT +kmod-mii
diff --git a/target/linux/generic/config-5.10 b/target/linux/generic/config-5.10
index 00c60c1227..11d05aba6f 100644
--- a/target/linux/generic/config-5.10
+++ b/target/linux/generic/config-5.10
@@ -2662,6 +2662,7 @@ CONFIG_IPV6_NDISC_NODETYPE=y
# CONFIG_IPV6_TUNNEL is not set
# CONFIG_IPV6_VTI is not set
# CONFIG_IPVLAN is not set
+# CONFIG_IPVTAP is not set
# CONFIG_IPW2100 is not set
# CONFIG_IPW2100_DEBUG is not set
CONFIG_IPW2100_MONITOR=y
diff --git a/target/linux/generic/config-5.4 b/target/linux/generic/config-5.4
index e8527f8068..8a93027d4d 100644
--- a/target/linux/generic/config-5.4
+++ b/target/linux/generic/config-5.4
@@ -2434,6 +2434,7 @@ CONFIG_IPV6_NDISC_NODETYPE=y
# CONFIG_IPV6_TUNNEL is not set
# CONFIG_IPV6_VTI is not set
# CONFIG_IPVLAN is not set
+# CONFIG_IPVTAP is not set
# CONFIG_IPW2100 is not set
# CONFIG_IPW2100_DEBUG is not set
CONFIG_IPW2100_MONITOR=y